Homematic Binding: "Channel not found for datapoint" errors for definitely existing channels

Hello, I’m also having a similar problem with the homematic binding (2.1.0) after updating to homegear 0.7.10 today. I have two window contacts but only one of them is getting updates (the problematic one has no “channels” data in the REST interface, the good one has). Everything is configured in files in my openHAB2 installation. Going back to homegear 0.7.9 didn’t solve the issue so I’m not sure whether this was only coincidence.

I can temporarily fix the problem by commenting out the problematic Thing and then commenting it in again. However after restarting the system the problem is back again. By setting the TRACE log level on the homematic binding I can see that homegear is actually sending the new state of the sensor but there appears no INFO nor ERROR message in the log.

After the regular RPC restart messages in the openHAB2 log I also see that only the good sensor is being updated.

Is there anything I can do? Do you need some additional information?

Hmm. Problem is back again (most likely never was gone completely :().

Not as severe as it was, but sometimes some devices don’t have all datapoints.

The devices in question are always HM-TC-IT-WM-W-EU or HM-CC-RT-DN (in my case the homegear variants of them).

If this is indeed a problematic to solve timing issue, wouldn’t it be a solution to (re)create the channels whenever that error occurs?

2017-10-24 08:56:08.512 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#RSSI_DEVICE'
2017-10-24 08:56:08.518 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#RSSI'
2017-10-24 08:56:08.520 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#SIGNAL_STRENGTH'
2017-10-24 08:56:08.550 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#ACTUAL_HUMIDITY'
2017-10-24 08:56:08.564 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#ACTUAL_TEMPERATURE'
2017-10-24 08:56:08.565 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#SET_TEMPERATURE'

I’m happy to provide any help to solve this issue, just ask what you need.

I tested today with some rules and events during startup, it’s impossible for me to reproduce. But i found a small issue at startup, that MAY cause the warning. But i don’t know if this is exactly your problem.

So i want to ask you, if you can try the latest snapshot once this PR has been merged. If the warning still occurs, please send me a trace log again.

English please, this is an international community forum.

Sorry for the german post, hmerk!

For me the problem is solved - these steps were necessary:

I’ve remove the 3 Homematic thermostat components with the paper ui via
Configuration -> Things -> Click on trash icon

Then i clicked “Search For Things” in “Inbox” an added the 3 thermostats back to the configuration

After a reboot i activated the homematic.items - entrys and the heating rules

Now everything is running without the “Channel not found for datapoint” message.


Update 21:58

I have to do the same (remove and add it again) with my homematic window contact!

Sorry for this beginner question but how can I install the snapshot build of the homematic binding? I followed the instructions in the FAQs, however after restarting openHAB the old version 2.1.0 seems to be pulled in as well (it was “Uninstalled” before restarting openHAB!):

openhab> feature:list|grep -i homematic
openhab-binding-homematic                   | 2.1.0            | x        | Started     | addons-2.1.0                | Homematic Binding

openhab> bundle:list|grep -i homematic
235 | Active    |  80 |     | Homematic Binding
237 | Installed |  80 | 2.1.0                  | Homematic Binding

REST shows me a 404 on my Homematic things in this situation.

Did you switch to openHAB 2.2 Snapshot as well or did you just upgrade the addons?

I switched to 2.2, removed everything and dropped the jar in /usr/lib/openhab2/addons folder.

My openHAB installation is still at version 2.1.0 (stable release), I only wanted to update the Homematic binding. Isn’t this possible? Would I mandatorily have to update openHAB as well? Thanks in advance.

I am not sure, but i don’t think it works. It can, but usually from release to release something changes.

That’s exactly the reason why i migrated everything to config files (things and items). I can easily change the openHAB release. I just need to copy my files and i am done.

Currently i am waiting on the new build including the fix (merge is done, but no new build yet).

I have the “Channel not found for datapoint” issue as well. I am using Homegear 0.7.12 and openhab 2.2 stable. At every other restart of openhab one or more devices have this issue. I stop homegear and openhab, restart both and it will probably be another device which will have this issue now or if I’m lucky, every device will work perfectly. Can I send any related logfiles to debug this.

There were some changes regarding data points in version 2.2 of the binding. The changes don’t affect all HM devices, but I do not remember what they were. There was a similar post here in the discussion forum with the same problem.
In Paper UI the only solution is to remove the items and add then rediscover them again.

I have all my HM devices in things files and I have reinstalled from scratch a few times lately. I don’t think that a rediscover will help, but I can try to recreate all things.

And since it will probably change on restart, I think that it is some sort of timing or whatever issue. The device which has the problem at one time will work again after a restart without any issue.

I have a similar setup and had the same issue. Currently it is not visible.

I cured most of the problems with reducing the load on startup by redefining the trigger elements.

e.g.: changed => changed from ON to OFF or changed from OFF to ON

I have now changed my setup from using an Odroid XU4 to a Intel X86 based system and the issue still occurs. I have quite a few rules that trigger during startup which might cause some overload during this time. I was thinking about renaming my .rules files to something else on shutdown and renaming them back to .rules after startup has finished. I will see if this makes a difference.

In OH1 gab es die Möglichkeit je nach Folder festzulegen, wie das Polling Intervall ist. Da wurde häufig empfohlen das Polling Intervall für rules höher zu setzen als für z.B. items. Das sollte das Problem doch auch lösen, aber leider finde ich keine Möglichkeit, wie ich in OH2 das Polling Intervall für die einzelnen Ordner anpassen kann. Hat jmd. ne Idee?

Hi, thank you!

actually restarting OH2 once with all things and items removed did fix my issues as well.

I also had OutofMemory exceptions because the Homatic bindung created >5.000 threads with “TIMED_WAITING on lock=java.util.concurrent.locks.AbstractQueuedSynchronizer” in 12h

Now everything works again

1 Like

i am also getting the „Channel not found“ error randomly on restarts. Last night i needed to restart openhab about 10 times to get all items working. Removing everything related to homematic also did not changed anything.
I also tried to remove rules that trigger on every change and use CHANGED FROM … TO instead but i have a few rules based on strings and number ranges where this is not possible.

I did not had that kind of problems with OpenHAB 1 so i think there is still a bug in the binding. Does anybody else still has these problems?

Is it possible to restart only the homematic binding without restarting OpenHAB competely?

Regards, Mark

Did you try that?

Sorry, needed some time to get the renaming workaround working in combination with the openhab-docker-image.
It seems to fix the problem.

Nonetheless I think the problem must be fixed.

The workaround with moving and renaming the rules does not really solve the problem.
I don’n need 3-4 restarts to get all items up, but still 1 or 2 restarts.
Any possibility this will be analyzed and fixed?