Homematic Binding: "Channel not found for datapoint" errors for definitely existing channels

Just came accross this issue when updating to lastest snapshot version and got loads of “Channel not found for datapoint” messages in my log. Mainly the RSSI and SIGNAL_STRENGTH points for all devices.
I’m using a normal CCU2.
Is it really required to migrate to homematic.things file setup? Till now I used the discovery functionality via PaperUI.
Is there any migration guidline? Something like sed’ing some PaperUI created config files, spitting the .things file config?
That would help a lot to setup the things file.

Hi @gerrieg,

built and test currently your last Pull-Request. It seems work so far. Only one thing. I get a lot of

2017-05-12 21:50:37.707 [INFO ] [ommunicator.AbstractHomematicGateway] - No event since 943 seconds from gateway 'homegear', restarting RPC server

messages now. After server restart device values will be updated. Tried to debug, but got no clue about the possible reason.

Any idea?

Thanks and kind regards,

Alexander

Hi @falkena

Which server did you restart? OH or Homegear?
Hmm, no idea, my last changes should have no influence on it. Can you reproduce this or was it unique?

Hi @gerrieg,

I’m running homegear. The error is reproducible. Got a little bit more clue. The

 serverSocket.accept()

in

BinRpcNetworkService::run()

throws an exception. I’ve not found any call to

getRpcCallbackURL

too. Hope it helps.

EDIT: INFO occures on both 2.0.0 release and 2.1.0 snapshot.

Thank you and kind regards,

Alexander

Hi,
I just would like to mention that I have exact the same warnings in my logs since I have updated to the stable version of OH 2.1:

2017-08-04 19:50:49.062 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'LEQ1189529:0#RSSI’
2017-08-04 19:50:49.064 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint ‘LEQ1189529:0#SIGNAL_STRENGTH’

My system:
A Pi3 with homegear and OP 2.1 stable and with mainly Homematic-devices

My systems seems to work though without any problems, so this is no blocking issue, still I would be glad to correct it and get rid of these warnings.

best regards
schroedinger

Hi,

if you remove the thing and add it again the problem should disappear.

Hi,

thank you for the advice.

However, to be honest - at the moment I do not dare to remove the thing for the following reasons:

  • it happened already twice that - when I tried to remove things or items via PaperUi - that I could not fully remove them, and they remained sometimes as a kind of “ghosted” (grey) item, which caused a “404 not found error” whenever I tried to remove it.
  • and the mentioned item is part of a group, I have tagged it with some ImperiHome-tags and I have mentioned in in some rules -> so I do not kn ow what will have if I try to remove it

-> for the moment I do not dare to try to remove it.

Nevertheless - thank you for the advice. I guess I will try it after I have made a full backup - and I will post then if it has worked.

1 Like

Thanks for this hint!! This worked!

Yesterday I updated to 2.1 stable (as previously I used some old snapshot of a pre-2.1 release) and this same problem occured again.

I have everything configured in *.things and *.items files and removed all Homematic-specific items and things, restarted it once without all items, stopped it, added the configuration files again and restarted OpenHAB and now it works again.

I am using 2.2 Snapshot and the error still exists. Moving everything to *.things file does not work either. (including deletion of all things)

This in combination with the auto-deleting all my things described https://community.openhab.org/t/homematic-homegear-problems/35077 is getting ugly for my installation. :frowning:

I am moving to 2.1 stable now, hopefully this is usable again.

I have found a solution, or better the root of the problem. At least in my special case.

I had several rules, which were iterating through groups checking states, sending messages, playing sounds, etc. Due to my lazyness, i triggered the on the “change” of the group state, which triggered the rules also on startup, when the item states where restored. Due to the group state most likely several times. :wink:

I changed the trigger to prevent the rules from being executed on startup and afterwards the problem of the missinng channels is gone.

Stressing openHAB during startup may also be a good idea to reproduce the problem.

@gerrieg, do you need more info to reproduce the problem to find a solution? I was almost always unable to restart openHAB correctly due to that problem.

Thank you for the info! This of course explains the behavior, the error message is correct but very misleading. I’ll try to reproduce it and find a solution.

Hello, I’m also having a similar problem with the homematic binding (2.1.0) after updating to homegear 0.7.10 today. I have two window contacts but only one of them is getting updates (the problematic one has no “channels” data in the REST interface, the good one has). Everything is configured in files in my openHAB2 installation. Going back to homegear 0.7.9 didn’t solve the issue so I’m not sure whether this was only coincidence.

I can temporarily fix the problem by commenting out the problematic Thing and then commenting it in again. However after restarting the system the problem is back again. By setting the TRACE log level on the homematic binding I can see that homegear is actually sending the new state of the sensor but there appears no INFO nor ERROR message in the log.

After the regular RPC restart messages in the openHAB2 log I also see that only the good sensor is being updated.

Is there anything I can do? Do you need some additional information?

Hmm. Problem is back again (most likely never was gone completely :().

Not as severe as it was, but sometimes some devices don’t have all datapoints.

The devices in question are always HM-TC-IT-WM-W-EU or HM-CC-RT-DN (in my case the homegear variants of them).

If this is indeed a problematic to solve timing issue, wouldn’t it be a solution to (re)create the channels whenever that error occurs?

2017-10-24 08:56:08.512 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#RSSI_DEVICE'
2017-10-24 08:56:08.518 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#RSSI'
2017-10-24 08:56:08.520 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:0#SIGNAL_STRENGTH'
2017-10-24 08:56:08.550 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#ACTUAL_HUMIDITY'
2017-10-24 08:56:08.564 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#ACTUAL_TEMPERATURE'
2017-10-24 08:56:08.565 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'OEQ0300665:2#SET_TEMPERATURE'

I’m happy to provide any help to solve this issue, just ask what you need.

I tested today with some rules and events during startup, it’s impossible for me to reproduce. But i found a small issue at startup, that MAY cause the warning. But i don’t know if this is exactly your problem.

So i want to ask you, if you can try the latest snapshot once this PR has been merged. If the warning still occurs, please send me a trace log again.

English please, this is an international community forum.

Sorry for the german post, hmerk!

For me the problem is solved - these steps were necessary:

I’ve remove the 3 Homematic thermostat components with the paper ui via
Configuration -> Things -> Click on trash icon

Then i clicked “Search For Things” in “Inbox” an added the 3 thermostats back to the configuration

After a reboot i activated the homematic.items - entrys and the heating rules

Now everything is running without the “Channel not found for datapoint” message.

:vulcan_salute:

Update 21:58

I have to do the same (remove and add it again) with my homematic window contact!

Sorry for this beginner question but how can I install the snapshot build of the homematic binding? I followed the instructions in the FAQs, however after restarting openHAB the old version 2.1.0 seems to be pulled in as well (it was “Uninstalled” before restarting openHAB!):

openhab> feature:list|grep -i homematic
openhab-binding-homematic                   | 2.1.0            | x        | Started     | addons-2.1.0                | Homematic Binding

openhab> bundle:list|grep -i homematic
235 | Active    |  80 | 2.2.0.201711012040     | Homematic Binding
237 | Installed |  80 | 2.1.0                  | Homematic Binding

REST shows me a 404 on my Homematic things in this situation.

Did you switch to openHAB 2.2 Snapshot as well or did you just upgrade the addons?

I switched to 2.2, removed everything and dropped the jar in /usr/lib/openhab2/addons folder.

My openHAB installation is still at version 2.1.0 (stable release), I only wanted to update the Homematic binding. Isn’t this possible? Would I mandatorily have to update openHAB as well? Thanks in advance.

I am not sure, but i don’t think it works. It can, but usually from release to release something changes.

That’s exactly the reason why i migrated everything to config files (things and items). I can easily change the openHAB release. I just need to copy my files and i am done.

Currently i am waiting on the new build including the fix (merge is done, but no new build yet).