Homematic Binding: "Channel not found for datapoint" errors for definitely existing channels

I have the “Channel not found for datapoint” issue as well. I am using Homegear 0.7.12 and openhab 2.2 stable. At every other restart of openhab one or more devices have this issue. I stop homegear and openhab, restart both and it will probably be another device which will have this issue now or if I’m lucky, every device will work perfectly. Can I send any related logfiles to debug this.

There were some changes regarding data points in version 2.2 of the binding. The changes don’t affect all HM devices, but I do not remember what they were. There was a similar post here in the discussion forum with the same problem.
In Paper UI the only solution is to remove the items and add then rediscover them again.

I have all my HM devices in things files and I have reinstalled from scratch a few times lately. I don’t think that a rediscover will help, but I can try to recreate all things.

And since it will probably change on restart, I think that it is some sort of timing or whatever issue. The device which has the problem at one time will work again after a restart without any issue.

I have a similar setup and had the same issue. Currently it is not visible.

I cured most of the problems with reducing the load on startup by redefining the trigger elements.

e.g.: changed => changed from ON to OFF or changed from OFF to ON

I have now changed my setup from using an Odroid XU4 to a Intel X86 based system and the issue still occurs. I have quite a few rules that trigger during startup which might cause some overload during this time. I was thinking about renaming my .rules files to something else on shutdown and renaming them back to .rules after startup has finished. I will see if this makes a difference.

In OH1 gab es die Möglichkeit je nach Folder festzulegen, wie das Polling Intervall ist. Da wurde häufig empfohlen das Polling Intervall für rules höher zu setzen als für z.B. items. Das sollte das Problem doch auch lösen, aber leider finde ich keine Möglichkeit, wie ich in OH2 das Polling Intervall für die einzelnen Ordner anpassen kann. Hat jmd. ne Idee?

Hi, thank you!

actually restarting OH2 once with all things and items removed did fix my issues as well.

I also had OutofMemory exceptions because the Homatic bindung created >5.000 threads with “TIMED_WAITING on lock=java.util.concurrent.locks.AbstractQueuedSynchronizer” in 12h

Now everything works again

1 Like

i am also getting the „Channel not found“ error randomly on restarts. Last night i needed to restart openhab about 10 times to get all items working. Removing everything related to homematic also did not changed anything.
I also tried to remove rules that trigger on every change and use CHANGED FROM … TO instead but i have a few rules based on strings and number ranges where this is not possible.

I did not had that kind of problems with OpenHAB 1 so i think there is still a bug in the binding. Does anybody else still has these problems?

Is it possible to restart only the homematic binding without restarting OpenHAB competely?

Regards, Mark

Did you try that?

Sorry, needed some time to get the renaming workaround working in combination with the openhab-docker-image.
It seems to fix the problem.

Nonetheless I think the problem must be fixed.

The workaround with moving and renaming the rules does not really solve the problem.
I don’n need 3-4 restarts to get all items up, but still 1 or 2 restarts.
Any possibility this will be analyzed and fixed?

Is there any solution for the channel not found for datapoint problem? I will now restart the xx time… Openhab at latest release version, homegear at last stable version.

Would be great to get any reply. After setting up everything new with openhabian problem occured again!
Thanks for any help

Please give us some more information, especially some log output would be helpful in order to se the error messages. Without knowing more about the device that causes the problem and the openHAB version you are using it won’t be easy to help you.

Hi Martin,
I have the latest stable 2.3 openhab with the homematic binding in 2.3
I don’t have any error message besides this (they occur every 2 minutes):

2018-10-14 00:57:48.241 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:0#RSSI_DEVICE'
2018-10-14 00:57:48.246 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:0#RSSI'
2018-10-14 00:57:48.250 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:0#SIGNAL_STRENGTH'
2018-10-14 00:57:48.258 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:0#LOWBAT'
2018-10-14 00:57:48.268 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#ACTUAL_TEMPERATURE'
2018-10-14 00:57:48.273 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#BATTERY_STATE'
2018-10-14 00:57:48.279 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#BOOST_STATE'
2018-10-14 00:57:48.284 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#CONTROL_MODE'
2018-10-14 00:57:48.290 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#FAULT_REPORTING'
2018-10-14 00:57:48.296 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#PARTY_START_TIME'
2018-10-14 00:57:48.302 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#SET_TEMPERATURE'
2018-10-14 00:57:48.307 [WARN ] [ematic.handler.HomematicThingHandler] - Channel not found for datapoint 'MEQ0792935:4#VALVE_STATE'

After a restart it might work or any other of my homematic devices might have the same problem. If the problem occures I cannot receive any data from it or send commands to it.

Is there anything I can lookup to help you to find the error?

Looking at the datapoint names it seems that it is a thermostat device. What kind of Homematic device it is? A normal one or a Homematic IP device?

Where did you define the bridge and things? In Paper UI or in text format? There are some special requirements regarding Homegear.

It is defined in a things file as follows:
Thing HG-HM-CC-RT-DN MEQ0792934
I don’t use the Paper UI for this. It is a normal non IP device.

I have to the same device and it works without any problems. But I am using Raspberrymatic instead of Homegear.
Maybe @gerrieg has an idea.

It’s not the device not working, it’s just some devices are sometimes not correctly initialized.

I have 15 HM-CC-RT-DN Thermostats and 10 HM-TC-WM-W-EU Wall Thermostats. Almost every restart, up to three devices are not being initialized with the correct channels. Always different devices.

So, looking at the devices itself will not help, it is the initialization which is not working correctly all the time.

The problem occurs mostly with these thermostats, maybe because these have this massive amount of configuration parameters. But i have also seen this with HM-Sec-SCO door/window contacts. (Also not a single one.)

The single thing which helped a bit is delaying the rule engine on startup like i described there:

But the problem is still there, it is just no longer that visible as it used to be.

I know that this problem exists, but I have no solution.

The Homematic binding is special in that it loads all devices from the gateway and generates all openHab metadata at startup. This ensures that new devices are ready for use immediately without having to manually create hundreds of metadata entries for each device.

I think it’s a timing problem at startup, either in the binding or in the framework. I can’t reproduce it in the development environment. I’ve checked the code several times, the device is not initialized until all metadata has been added to openHab.

Without reproducibility in the development environment this will be hard to find.