Homematic binding showing in INBOX only SERIAL instead of device NAME

Hi all

My installation and what I intend to do
I have a fully working OH2.4 installation on Synology VMM and a raspberrymatic version 3.51.6.20200229-ccu3. On OH2.4 on debian 9 and all works (installation without Openhabian).
=> Now I want to migrate to OH2.5 and decided to start from scratch a paralell installation.
=> I created a new virtual server on VMM Synology with debian 10 and installed openhabian (correct Java version is ensured by Openhabian).
=> Installation went well and I could connect without issue to the CCU3.

Problem description

  1. When I search for new devices, the OH2.5 shows in the inbox all devices, BUT instead of showing the name of the device like in version 2.4 (ex. Buero-Door-Sandkasten), it shows the serial name (ex. MEQ1597041).
    Example of an entry as it is shown in the INBOX in version 2.5
    MEQ1597041
    Funk-Tür-/ Fensterkontakt
    MEQ1597041
    Example of an entry as it is shown in the INBOX in version 2.4
    Buero-Door-Sandkasten
    Funk-Tür-/ Fensterkontakt
    MEQ1597041
  2. HMIP-SWDO devices (door contacts) are listed as UNKNOWN devices in OH2.5 ,while they are recognized in OH2.4.
    0009156993C2EB
    Unknown device
    0009156993C2EB

Expected behvior

  1. After detection the CCU3 devices should be shown with NAME and Serial and not with Serial and Serial
  2. Devices HMIP-SWDO are recognized as they were in v2.4

Can you please support me?

For my 2nd point, I guess I found following answer on the official homepage (https://www.openhab.org/addons/bindings/homematic/):
" The Homematic IP Access Point does not support this API and and can’t be used with this binding."

=> It only says that the Homematic IP AP is not supported, but probably this explains why Homematic IP devices are not recognized?

Did you try to restart openHAB after the installation of the Homematic binding? I sometimes had the same problem with the display of of the names but it disappeared after a restart.

Many thanks for the answer. I did give it now a try, deleted all items from the Inbox and then restarted the virtual server.
=> Unfortunately it is still the same problem.

I tried to open a BUG-Report but, did not see on Github the possibility. Do you have maybe an idea, how to conntact the developper?

As I did a full new installation, I am pretty sure it’s a bug.

My CCU is v3 (latest version) and running on a raspi.

Many thanks

You can open a bug request here https://github.com/openhab/openhab-addons/issues , but I am not sure whether it really is a problem in openHAB itself. The original people responsible for the binding are currently not active. Therefore I try to help as much as I can at the moment.

HMIP devices are definitly working with the latest version of openHAB and I did not see any similar problem report before.

Did you check the firewall options in both the CCU and on the new virtual server (see also: https://www.openhab.org/addons/bindings/homematic/)? It is important that ports 9125, 9126 are open on your VM where you have installed openHAB. You should also check the callback IP address in bridge configuration. If you have mutliple IP addresses in your VM you must make sure that you use the right one.

If you think that everything is configured correctly, please perform the following steps:

  1. set log mode to TRACE for the Homematic binding
  2. stop openHAB and delete openhab.log
  3. start openHAB and restart a discovery

Post openhab.log.

Many thanks that you take some time, to support me with my issue.

Firewall
OH2.5: Here I have not installed any Firewall, but did anyhow control it.
CCU3: Here the FW settings must be ok, because the connection to the productive server works.

OH 2.5 Bridg configuration
Gateway address: this is set to the ccu3 (192.168.20.80)
Callback option was empty, I set it to the IP of the VM 192.168.20.240

IP adress of VM
I have only 1 IP address. Setup is similar to the productive VM which just runs alongside and does not show this problem (OH2.4 server)

=> After controlling the above items, I deleted all items of the INBOX of OH2.5 and started again a search
=> Like before it finds all devices but shows the devices as follows:
NEQ0955270
Funk-Klingelsignalsensor
NEQ0955270

My conclusion is that the conection is working, but the wrong data fields are interpreted.
=> next step,… I create the trace log

So here we are. I did…

  • ssh karaf@localhost -p8101
  • log:set TRACE org.openhab.binding.homematic
  • Shut-down openhab
  • del /var/log/openhab2/openhab.log
  • start openhab
  • went into paper ui and saw that all devices were found but again with serial and not names
  • restarted search
  • copied the log file
    http://s000.tinyupload.com/?file_id=70887836279510568897

As I fear this log is far to big, I did a 2nd one…

  • I deleted all found items in the INBOX
  • deleted the log file of the running openhab
  • ssh karaf@localhost -p8101
  • stop org.openhab.binding.homematic
  • log:set TRACE org.openhab.binding.homematic
  • start org.openhab.binding.homematic
  • went into paper ui and inbox… all devices were found but again with serial instead of name
    http://s000.tinyupload.com/?file_id=09434147894954335320

I hope this is what you need to have a look?

What I do not understand…
=> it looks clearly as the new binding uses the wrong data field (serial) as the name)
=> but as you have a running OH2.5 version and you do not see that behavior it must be my setup
=> but with OH2.4 it works all well and found devices show the CCU3 name. Only with OH2.5 (the new server) I see this issue.

The only difference between the 2 server is, that the new one installed openhab by openhabian and not manually, like for the production server

Good morning,

it seems that something is not OK with the binding installation. The Trace contains messages like this:

Description not found for: MAINTENANCE|SABOTAGE, SABOTAGE

It seems as if some internal properties files can’t be read. This would explain why you don’t see the descriptions.

You could try to clean the cache directory and restart openHAB (+ discovery). If this does not help you could install this version: https://github.com/MHerbst/openhab-addons-test/raw/master/org.openhab.binding.homematic-2.5.3-SNAPSHOT.jar to your addons folder (to do this, please uninstall the Homematic binding, clear the cache and then copy it to the addons folder).

My installation was done manually and I have started from 2.3, then 2.4 and now the latest 2.5 without any problems.
Another difference is that I am not using Cuxd.

Perfect… I did…

  • stop oh2.5
  • openhab-cli clean-cache
  • start oh2.5
  • went into paper UI Inbox and deleted all found entries.
    => Same issue, all items are found but the description is = serial

Now I try to install manually your binding…

** UPDATE **
Following dependencies had to be installed in Karaf
feature:install openhab-transport-upnp
feature:install openhab-transport-serial

Now your bridge works, but I still see all things like this…

NEQ1835025

Funk-Tür-/ Fensterkontakt
NEQ1835025

Interestingly I see the correct names for all Cuxd devices. Only ccu3 devices are point to serial.

Btw the devices mentionning sabotage, are all the Homematic-IP devices that run well on CCU3 and with OH2.4

Now I narrowed down the issue.
=> It has to do with the latest Update of CCU3. It seems that it changed the layout and now also in OH2.4 it shows the same behavior.

So the problem will hit everybody, with the newest CCU3 firmware. So the solution will have to be done in the code :frowning:

Sorry, for answering a bit late.

So the problem will hit everybody, with the newest CCU3 firmware. So the solution will have to be done in the code

That’s strange, I am using the same Raspberrymatic version 3.51.6.20200229 without any problems. Maybe it has to do with CuxD. Did you try to uninstall it for a test and try it without Cuxd.