Homematic Binding "Things" file configuration

Hi all,

I appreciate some advice for a manually Things file configuration for my Homematic devices. I was able to get it working but a few things are still unclear. At the end the Gateway-Extras virtual devices causes pain.

I’ve followed this approach: https://www.openhab.org/addons/bindings/homematic/#thing-configuration
My current homematic.things file looks like this:

Bridge homematic:bridge:ccu2 [ gatewayType="ccu", gatewayAddress="", callbackHost="" ]
	Thing HM-CC-RT-DN	NEQ1230892	"CCU2 Heizung Kinderzimmer"	@	"Kinderzimmer"
	Thing HM-Sec-RHS	OEQ0963890	"CCU2 Fenster Kinderzimmer"	@	"Kinderzimmer"
	Thing HM-Sec-RHS	MEQ0222761	"CCU2 Fenster Schlafzimmer"	@	"Schlafzimmer"
	Thing HM-CC-RT-DN	MEQ1882938	"CCU2 Heizung Schlafzimmer"	@	"Schlafzimmer"

	Thing HM-Sec-RHS	NEQ1761476	"CCU2 Fenster Wohnzimmer"	@	"Wohnzimmer"
	Thing HM-CC-RT-DN	NEQ1231073	"CCU2 Heizung Wohnzimmer"	@	"Wohnzimmer"

	Thing HM-WDS10-TH-O	OEQ0087107	"CCU2 Funk-Temperatur-/ Feuchtesensor Garten"	@	"Garten"

Bridge homematic:GATEWAY-EXTRAS-CCU2:ccu2:GWE00000000 [ gatewayType="ccu", gatewayAddress="", callbackHost="" ]

With this I can see all almost each device configured in the “bridge” as “Online” in the PaperUI. I’m also able to access the channels by an .items file and bring it up to a sitemap. So the channel linking in my homematic.items files seems ok as well. However, there are 2 Heaters AND the Bridge itself showing up as “Offline” as you can see in the screenshot below (the outdoor humidity sensor is ok, it has no batteries yet…)? In the sitemap I can see the values for the Heater but they don’t change. I don’t know why they appear as “Offline” here? Is this a syntax issue in my things file above?
What’s the correct way/syntax to get the Gateway up and running? In the screenshot you can also see that in the PaperUI it appears but as “Initializing”. If I click on it I’m able to see all my parameter as channels, coming from the CCU2. The log file regarding the Gateway says the following:

2018-10-24 14:14:36.733 [ERROR] [ome.core.thing.internal.ThingManager] - Exception occurred while calling thing handler factory 'org.openhab.binding.homematic.handler.HomematicThingHandlerFactory@15afd15': Created handler of bridge 'homematic:GATEWAY-EXTRAS-CCU2:ccu2:GWE00000000' must implement the BridgeHandler interface.
java.lang.IllegalStateException: Created handler of bridge 'homematic:GATEWAY-EXTRAS-CCU2:ccu2:GWE00000000' must implement the BridgeHandler interface.
	at org.eclipse.smarthome.core.thing.binding.BaseThingHandlerFactory.registerHandler(BaseThingHandlerFactory.java:125) ~[?:?]

What I’m doing wrong or what I’m still missing?

My Homematic Firmware version: 2.35.16
Homematic Firewall allowes full access to XML-RPC API and Remote HomeMatic-Script AP.

[Edit] And my openhab2 runs on a RPi3:

Thanks in advance!

I just added my Homematic Devices yesterday. The Gateway Extras is just another thing, so add it to the existing ccu2 bridge like your other things:

Thing   GATEWAY-EXTRAS-CCU2 GWE00000000     "CCU2 - Gatway-Extras"