Homematic Bridge - OFFLINE - COMMUNICATION_ERROR Jetty start failed

I found one threat about this error, but the restart solution was not mine.

I am running OH2 on docker container.
This is my Things config:

Bridge homematic:bridge:ccu3 [ gatewayAddress=“”, callbackHost=“”, xmlCallbackPort=“9125”, binCallbackPort=“9126” ]
Thing HmIP-BROLL 001118A9A594BC //Büro-Rollo-N
Thing HmIP-BROLL 001118A9A594B9 //Bad-Rollo-SO

the funny thing is, if I am going to Configuration Things Homematic Bridge
and show properties I am receiving this:

modelId CCU2
serialNumber PEQ2183643

But I am running a CCU3 with different SN???

Thanks for your help

The TCP socket bind implementation changed from InetSocketAddress(config.getBinCallbackPort()) to InetSocketAddress(config.getBindAddress(), config.getBinCallbackPort()) where getBindAddress() defaults to callbackHost. In other words the Homematic bridge isn’t binding to any interface anymore, but the interface of callbackHost (which is good in regards of security). Now since in Docker the container’s network interface typically is a virtual one, an attempt to bind against the hosts’s physical interface will fail (and Jetty won’t bring the Thing online). For that reason a new parameter bindAddress was introduced and should be set to the container’s virtual IP (e.g.

Unfortunately this new parameter wasn’t exposed in the Thing configuration of the binding version coming with the Add-ons installer of openHAB 2.4.0 Paper UI. However this is fixed in the current version of Eclipse SmartHome project (https://github.com/eclipse/smarthome). A solution would be building your own version form there, uninstalling the binding from Paper UI Add-ons and dropping the custom built org.eclipse.smarthome.binding.homematic_0.11.0.*.jar file to the .../openhab/addons directory. The Configuration Parameters of the Homematic Bridge in Paper UI will then also show a “Bind Address” section as mentioned above. Using bindAddress="x.x.x.x" in a .things file will also work then.

Another solution would be exposing the host’s physical network stack to the container (--network="host"). That way the container would have the same “view of the network world” like the host and also would be able to bind against the interface (not recommended since giving up extra security by Docker network isolation).


I am running OpenHAB 2.5.0 M2 on my Windows machine. I had to reboot my device today and since then all is working properly except my HomeMatic Binding.

My HomeMatic devices are all working fine but I can’t connect the binding to many Bridge because of this Jetty error.

I tried several Google results but had no success! So can anyone help me?

Update to the 2.5 stable build is not successful and everyone my complete environment crashes!

What is the reason for this error? What can I do?