Homematic CCU2 Gateway Initialization

Hello Everybody, iam actually really new to the topic.

I just installed Openhab on my NUC and now iam trying to integrade the Homematic Devices into Openhab.
Unfortunately the CCU2 stucks on Initializing for a very long time when i manually add the device.
If i try it with discovery Open-Hab finds nothing. I have no idea what could be wrong. I have added all IP-Adresses of the Router and the Openhab device to get access to the CCU2.

That is the log:

  2020-02-07 17:11:45.503 [WARN ] [ternal.discovery.CcuDiscoveryService] - Homematic CCU discovery: discovery not possible, no broadcast address found
2020-02-07 17:13:01.208 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '4252ccff' not available, disabling support
2020-02-07 17:13:01.238 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'CUXD' on gateway '4252ccff' not available, disabling support
2020-02-07 17:13:01.301 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=2.49.18,address=OEQ1011507,rf=true,wired=false,hmip=true,cuxd=false,group=true]
2020-02-07 17:13:01.311 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.IllegalArgumentException: hostname can't be null
	at java.net.InetSocketAddress.checkHost(InetSocketAddress.java:149) ~[?:1.8.0_242]
	at java.net.InetSocketAddress.<init>(InetSocketAddress.java:216) ~[?:1.8.0_242]
	at org.openhab.binding.homematic.internal.communicator.server.XmlRpcServer.start(XmlRpcServer.java:82) ~[?:?]
	at org.openhab.binding.homematic.internal.communicator.AbstractHomematicGateway.startServers(AbstractHomematicGateway.java:254) ~[?:?]
	at org.openhab.binding.homematic.internal.communicator.AbstractHomematicGateway.initialize(AbstractHomematicGateway.java:192) ~[?:?]
	at org.openhab.binding.homematic.internal.handler.HomematicBridgeHandler.initializeInternal(HomematicBridgeHandler.java:110) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_242]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_242]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) ~[?:1.8.0_242]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[?:1.8.0_242]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_242]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_242]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]

It seems that openHAB can’t find the CCU in your network. Did you configure the CCU’s firewall as described in the binding documentation?
Are your NUC and the CCU running in the same subnet? You could try to ping the CCU from the NUC to make sure that it is accessible.
What OS is running on your NUC?

Hello Martin,

thank you very much for your respond. I tried to ping the CCU from the NUC. That worked:

--- ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9012ms
rtt min/avg/max/mdev = 0.631/0.858/0.953/0.101 ms

I installed Ubuntu 16.04 LTS on my NUC. They are both in the same network but connected to different routers.
Thats my configuration:
Do you have any other hints?
When i try to add i manually it is always in the state uninitialized but at lead i can find my other homematic devices than.

Hello Martin,

quick update. Tonight was electrical power blackout. After that the CCU2 got a new IP-Adress and all the Homematic devices are discoverd now by openhab :slight_smile:

What a blackout like this can be good for :slight_smile:
But in general it is better if the IP address of the CCU does not change.

For anyone else interested, I ran into exactly the same problem while upgrading from a Pi to a debian intel NUC. After following the same sequence of troubleshooting (pings, network checks, restarts, etc) I eventually gave up decided to force the CCU2 onto a new address (via WebUI and UniFi in my case), and lo-and-behold, everything started working again. I have no idea why.

This is a very strange bug, and probably hard to reproduce.