Homematic connection lost when router reboots

Hi I have a connection with homematic ccu3. Every night I reset my router, to prevent possible problems with this router. But when the router has been restarted the connection between opehab and homematic is lost. I can only get the connection back when I restart openhab. I am using openhab 3.2.0.
Does anyone know a solution to this problem?

Hi Frank,

I thought that this problem was solved for most situations. But maybe there is another situation for a router restart. What happens exactly? Remains the bridge in offline state or only some devices?
It can take several minutes until the connection is restored.
Can you set the log level for the binding to DEBUG, restart the router, wait some minutes and post the relevant excerpt from openhab.log.

Hi Martin,
I can tell you now that everything is online (bridge, window contacts, etc), but the window contact states are not update in openhab after the router has been restarted.
I will send you the log logfile later.

Hi Frank,

are the Window contacts HmIP devices? BTW: what happens if you open/close a window? Is there a message about an incoming event in the log?

Maybe I can try to reproduce the problem. How long does it take until the router is fully back again and the binding and the CCU can communicate again?

Hi Martin,
I tried it with the debug option on, but no extra logging ( I have to look up how to do it correctly). But what I found if that is when I shutdown the router my self and waited 6 min and then restart de router everything works fine. When I restart the router at night I use a clock socket which can only turn off the power for at least 15 min (shorter is not possible).
So it looks like there is timer of about 15 min in the binding, is that possible. Because in the beginnen it work fine after the nightly reboot and now it is mostly not working after the 15 min reboot.

1 Like

I could offer to do tests as well if it would help. I remember having had problems on that end as well months ago, but haven’t had router restarts lately and also didn’t want to provoke openHAB willingly. Though if it would help I could go down this path again, reboot the router and provide logs.

A debug log for the time during and after the router reboot would definitely be interesting. I would then also try to reproduce it.

I still have this error. At least once a week, my homematic binding connection is lost. Yesterday I could see a correlation to a firewall upgrade, where the connection was lost during a reboot. It seems not to recover from this. I also can only restart OpenHAB to make it work again.
To better detect outages, I defined a rule that should fire if the thing status changes, but this doesn’t fire either. The rule itself is working, if I manually disable the homematic bridge, the message is sent. But not if it acutally happens (which might be because in that moment, the internet connection is not available at all.

I got the same issue, no updates are received from the CCU, if i check the Thing it is emtpy.
After Reboot of CCU and OH everything is ok.

same here but it is sufficient to restart OpenHab only, no need to restart CCU.

disable and enable the CCU3 Thing seems also work.

For me, that didn’t work. I need to restart OpenHAB…

Why don’t you just restart your Homematic Binding as well after the Router is back online?

sudo /usr/bin/sshpass -p your_password ssh -p 8101 openhab@localhost “bundle:restart

That should do the trick and bring the ccu and all devices back online.
I made a small shell script which finds the bundle ID when you provide it with a unique part of the bundle name and restarts the bundle.

That’s also an option, but no solution :slight_smile: Since all connections are available, the binding should recover automatically. I have a rule informing me when the binding is offline, but it’s very uncomfortable if I need to restart OH all the time (e.g. each time I need to enter a new 2FA for the icloud binding). Restarting the binding only eases this a bit, but is not satisfiying :slight_smile:

Could you provide the script? I would try to integrate this in my check rule to restart the binding if it’s offline.

Save as shell script and call it with (uniqe part of) the name of the bundle to restart:

# Find bundle ID for bundle name
bundleName=`sudo /usr/bin/sshpass -p <your_password> ssh -p 8101 openhab@localhost "bundle:info | grep -i $1" 2>/dev/null | sed -e 's/.* :: \(.*\)/\1/'`
bundleID=`echo $bundleName | sed -e 's/.*(\(.*\))/\1/'`

# bundle ID found
if [ "$bundleID" != "" ]
  sudo /usr/bin/sshpass -p <your_password> ssh -p 8101 openhab@localhost "bundle:restart $bundleID" 2>/dev/null
  sudo /usr/bin/sshpass -p <your_password> ssh -p 8101 openhab@localhost "bundle:list $bundleID" 2>/dev/null

Never the less you should find out why your binding is offline. Could be due to long response times from the CCU. CCU2 becomes very slow with increasing number of devices. That’s why I changed to pivCCU. Since then there were no more offline problems with Homematic.
The script is a relict from the times with CCU2 and Keba binding on OH 2.5.