Homematic Dimmer doesn't work

  • Platform information:
    • Hardware: RasPi 4 2GB
    • OS: Mac OS 11.1 Big Sur
    • Java Runtime Environment: JavaScriptCore 16610
    • openHAB version: openHAB 3.0.0

Hi Community,
I am a beginner of OpenHAB and do have some experience with configuration of Homematic WebUI and Pocket Control.
So I am starting with creating model and things (following the example from Yannik Schaus in the openHAB Virtual MeetUp 2020)
The first thing witch is running is a switched HomematicIP socket :slight_smile:
But the integration of Homematic dimmer HM-LC-Dim1T-FM doesn’t work.
(Any activities with the slider do have no reaction at the CCU3.)
There is a reaction at CCU3 and the dimmer is in contact.
The slider does have a range from 0% to 1% only.
It might be a question of configuration of the related item or thing.

When I config the dimmer as a switch, I can the lightbulb switch on/off but not dimming.

UID: homematic:HM-LC-Dim1T-FM:3014F711A0001F98A9A58463:OEQ1004590
label: Dimmer Couchtisch
thingTypeUID: homematic:HM-LC-Dim1T-FM
bridgeUID: homematic:bridge:3014F711A0001F98A9A58463

  • type: Dimmer
  • category: lightbulb
  • class: Point
  • property: light
  • relatesTo: Property_Light
  • isPointOf: DimmerEsstisch
    No profile

Many thanks for your support

Hi Community, the problem is solved, a beginners failure :disappointed:

how did you solve the Dimmer. I have a similar problem, just adding some Homematic Dimmers for the first time, and also just switched to OH3. (with seperate Raspberrymatic)
Homematic Dimmers send and expect 0-100.
Openhab Channel in Dimmer configuration ranges from 0-100% = 0 - 1

I’d like to set up a slider / Dimmer item in OH that outputs 0-100 and reads it back as well. Tried with JS conversions, but could not get that to work.


my problem was, when I configured the dimmer item, with the test button. I could only switch between 0% and 1%.
But after configuration the item in the sitemap I set the range from 0 to 100. It worked very well.
But after testing and deleting first rules my OH3 configuration is defect now.
So I am testing ioBroker now.

I still have that problem.

I use openhabian 1.6.3 with openhab 3.0.1 and a CCU3.
My OH2.5 setup worked fine but now i have problems with OH3

I migrated my configfiles to OH3 and the Homematic dimmers (not the IP) now only accept values in the range from 0-1%.
The basic-UI sitemap slider goes from 0-100% but resets every value above 1% to 1%.


Please try this test version: GitHub - MHerbst/openhab-addons-test You will have to remove the dimmer things and re-create them again.


Thanks @MHerbst. The updated binding fixed the scaling.

Worked like a charm, thank you

1 Like

Hallo all, I have the same problem.
I saw the addon has a version number like 3.1.0,but is should work for OH 3.0.1, right ?
Regards Markus

And a question to Jan-Marcus, could you short explain how you created the item. Could be that I made wrong completely.

Regards Markus

Hello all, I installed openHABian v1.6.4 completely new.
Now I got thisproblem with the snap-shot:
021-04-24 20:59:17.500 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.homematic-3.1.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.homematic [118]

Unresolved requirement: Import-Package: org.openhab.core.config.core

-> Export-Package: org.openhab.core.config.core; bundle-symbolic-name="org.openhab.core.config.core"; bundle-version="3.0.2"; version="3.0.2"; uses:="com.google.gson,org.openhab.core.common.registry"

   org.openhab.core.config.core [139]

     Unresolved requirement: Import-Package: org.openhab.core.common; version="[3.0.0,4.0.0)"

       -> Export-Package: org.openhab.core.common; bundle-symbolic-name="org.openhab.core"; bundle-version="3.0.2"; version="3.0.2"

          org.openhab.core [129]

            Unresolved requirement: Import-Package: tec.uom.lib.common.function; version="[1.0.0,2.0.0)"

            Unresolved requirement: Import-Package: org.osgi.service.component; version="[1.4.0,2.0.0)"

              -> Export-Package: org.osgi.service.component; bundle-symbolic-name="org.apache.felix.scr"; bundle-version="2.1.16"; version="1.4.0"; uses:="org.osgi.framework"

                 org.apache.felix.scr [49]

                   Unresolved requirement: Import-Package: org.osgi.util.promise; version="[1.0.0,2.0.0)"

Unresolved requirement: Import-Package: org.openhab.core.common

-> Export-Package: org.openhab.core.common; bundle-symbolic-name="org.openhab.core"; bundle-version="3.0.2"; version="3.0.2"

Unresolved requirement: Import-Package: org.openhab.core.config.core.validation

-> Export-Package: org.openhab.core.config.core.validation; bundle-symbolic-name="org.openhab.core.config.core"; bundle-version="3.0.2"; version="3.0.2"; uses:="org.openhab.core.i18n,org.osgi.framework"

at org.eclipse.osgi.container.Module.start(Module.java:444) ~[org.eclipse.osgi-3.12.100.jar:?]

at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[org.eclipse.osgi-3.12.100.jar:?]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.4]

at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.4]

2021-04-24 20:59:29.756 [INFO ] [org.openhab.ui.internal.UIService ] - Started UI on port 8080

2021-04-24 20:59:43.044 [INFO ] [org.openhab.ui.internal.UIService ] - Stopped UI
Regards Markus

This version of the Homematic binding is not compatible with the OH version installed by openHABian. You could either switch to the latest OH 3.1 snapshot or remove the binding from add-ons folder and use the one that is delivered with openHABian.

But with the verion which is coming witn OH3 the scaling of the dimmer is only from 0-.

I deleted the addon and I cleaned the cache and the system is completely down now.
I have other problem instead the scaling at the moment.


I got it running again, but I have now a bad scaling for the dimmer:

Regards Markus

This should work correctly with the latest test version of the binding. Unfortunately it will only work with a snapshot version because of some changes in OH Core. You can either wait for 3.1 or switch to a snapshot and install the test version.