[Homematic] Error with binary RPC

Hi There,

latest nightly 2.3.0 1195 new error with homematic. On the other side is a homegear system that worked without problems. Please can someone confirm that this error ist based on the homematic binding or homegear or whatever :slight_smile: With this error the bridge is offline and no homematic device is working.

2018-01-24 10:40:06.544 [ERROR] [nicator.server.BinRpcResponseHandler] - No BinX signature
java.io.UnsupportedEncodingException: No BinX signature
        at org.openhab.binding.homematic.internal.communicator.message.BinRpcMessage.validateBinXSignature(BinRpcMessage.java:91) [214:org.openhab.binding.homematic:]
        at org.openhab.binding.homematic.internal.communicator.message.BinRpcMessage.<init>(BinRpcMessage.java:79) [214:org.openhab.binding.homematic:]
        at org.openhab.binding.homematic.internal.communicator.server.BinRpcResponseHandler.run(BinRpcResponseHandler.java:44) [214:org.openhab.binding.homematic:]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]


Hi Thomas,

I currently have a lot of other issues with my system but I could see the same error in my logs after updateing to build 1195 and before breaking it completely. :sob:

Homegear or anything was not changed here, so guess it is somehow related to update to build 1195.


Hi Christian,

thanks could you post which version of homegear you are using. I have postet the error in the homegear forum as well.


homegear -v:

Homegear version 0.7.14-1563
Copyright (c) 2013-2017 Sathya Laufer

Git commit SHA of libhomegear-base: -
Git branch of libhomegear-base:     -
Git commit SHA of Homegear:         -
Git branch of Homegear:             -

PHP (License: PHP License):
This product includes PHP software, freely available from <http://www.php.net/software/>
Copyright (c) 1999-2017 The PHP Group. All rights reserved.

I opend an issue at github

Please include the link to your issue.

For the sake of completeness:

After updating homegear to version 0.80-1988 and openhab to latest nighty 1197 the error is gone.

Based on This i will close the issue in guthub.