Homematic HM-CC-VG-1 heating groups broken in OH 3.2

I upgraded my OpenHAB instance from 2.5 to 3.2.
All things and items are configured using text files.
After the upgrade all heating groups (HM-CC-VG1) stopped working. On startup I see the following error message in openhab.log (linebreaks added by hand):

[WARN ] [ommunicator.AbstractHomematicGateway]
Can't load device with address 'INT0000008' from gateway 'ccu':
java.util.concurrent.ExecutionException: java.io.EOFException: 
{io=0/0,kio=0,kro=1}->HttpConnectionOverHTTP@236f05f4(l:/ <-> 
{req=HttpRequest[POST /groups HTTP/1.1]@6856a0a6[TERMINATED/null] 
res=HttpResponse[null 0 null]@61c74937[PENDING/null]})
(rsp=IDLE,failure=null)[HttpParser{s=CLOSED,0 of -1}]]

And in the events.log:

Thing 'homematic:HM-CC-VG-1:ccu:INT0000008' changed from UNINITIALIZED (BRIDGE_UNINITIALIZED) to INITIALIZING
Thing 'homematic:HM-CC-VG-1:ccu:INT0000008' changed from INITIALIZING to OFFLINE (CONFIGURATION_ERROR): Device with address 'INT0000008' not found on gateway 'ccu'

This happens reproducible on every OpenHAB startup for all my heating groups.

The homematic bridge is configured as:

Bridge homematic:bridge:ccu [ gatewayAddress="homematic.sail.spinnaker.de", callbackHost="" ]
    Thing HM-RCV-50            BidCoS-RF     "CCU2"
    Thing HM-CC-VG-1           INT0000008    "HeizungRolandVirt"

While the items are configured as:

Switch Gr_Roland_Mode_Comfort   {channel="homematic:HM-CC-VG-1:ccu:INT0000008:1#COMFORT_MODE"}
Switch Gr_Roland_Mode_Lower     {channel="homematic:HM-CC-VG-1:ccu:INT0000008:1#LOWERING_MODE"}
Switch Gr_Roland_Mode_Boost     {channel="homematic:HM-CC-VG-1:ccu:INT0000008:1#BOOST_MODE"}
Switch Gr_Roland_Mode_Auto      {channel="homematic:HM-CC-VG-1:ccu:INT0000008:1#AUTO_MODE"}
Number Gr_Roland_SollTemp  "Soll-Temperatur Roland [%.1f °C]" <temperature> (All, OG_Roland, RRD, gT_Roland) {channel="homematic:HM-CC-VG-1:ccu:INT0000008:1#SET_TEMPERATURE"}

All this worked with 2.5 without problems, and is broken after the upgrade.

Any idea, what happened here?
Do the heating groups work for someone else in 3.2?


Hey Roland,

same for me. All heating groups stopped working. The discovery mode of the binding is also unable to detect the groups.

I hope that someone can fix this issue soon.



I have got several heating groups and all are working without any problems. I have defined everything in Main UI. Can you try and configure the Bridge and the Group Things in Main UI?
You can also try to use an IP address for the gateway address. Maybe this helps.

I have neve seen an exception like this before. It does not look like one of the normal messages from Homematic. If the configuration in Main UI does not work, please enable the DEBUG log mode for the binding and and then post the openhab.log file.

BTW: what kind of CCU are you using?

I use a CCU2 running with 2.57.5 (yes, I should upgrade to 2.61.7, but I don’t expect a change there).

I never used Basic UI for configuration (only for reading out device names and the like), since I prefer to have all configuration in config files, that I can edit by hand or scripts.

I restarted OpenHAB wit debug logging for homematic binding enabled.
You find the result at https://www.spinnaker.de/tmp/homematic.log
I don’t fully understand, what I see there. On the one hand I see the WARN messages, that INT000* cannot be loaded and INFO messages, that the HM-CC-VG-1 things try INITIALIZING, but then the become OFFLINE.
On the other hand I see DEBUG messages telling me that several values are received for INT000* datapoints.

But the mentioned datapoints do not seem to work in the corresponding items, that I defined.

An in Main UI the virtual groups all show up as OFFLINE with “CONFIGURATION_ERROR” “Device with address ‘INT0000003’ not found on gateway ‘ccu’” (same for all other virtual groups).

Could this be a timing issue with the old CCU2? In the meantime I updated the bridge configuration to use “callbackRegTimeout=180, timeout=30” (as suggested in the documentation for CCU2)?
Maybe this has something to do with [homematic] some devices offline (CONFIGURATION_ERROR) after restart of openHAB when using large number of homematic devices · Issue #11969 · openhab/openhab-addons · GitHub? But I have no idea how to try out the patched binding (is there a way to download the artefacts from github actions and install them as a replacement of the 3.2 addon?)


I also updated the bridge configuration to the parameters mentioned by Roland:

I updated the bridge configuration to use “callbackRegTimeout=180, timeout=30” (as suggested in the documentation for CCU2)

The heating groups are now at least discoverable but now I stuck on “Device with address ‘INT0000001’ not found on gateway ‘LEQ0115707’” too.

A little update on my problem: As I came from 2.5 to 3.2, I wasn’t sure which version introduced the problem.
Today I tried out 3.0.4 and 3.1.1 and the problem doesn’t occur with these versions, but only with 3.2.0.
So currently I run 3.1.1 (with the Log4shell workaround) and this looks much better than 3.2.0 for me, since the Homematic heating groups now work as expected.

I just opened an github issue for this: [homematic] Heating groups broken after upgrade from 3.1 to 3.2 · Issue #12080 · openhab/openhab-addons · GitHub