Homematic-IP already under development?

Hi all,

I received some homematic ip “Pluggable Switch and Meter” today and after the required firmware update they work nicely with CCU2. That brings up the question whether there is already a binding under development? As the ip interface uses a different port, the actual binding cannot handle it and returns a NullPointerException.

Wish all of you some relaxed days.

br Matthias

Should be working with the homematic binding and homegear.


Why do you think so? Any more details?

I tried as I wrote and because of the different port it is logical that it fails and doesn’t work without any changes in the binding.

But I would be happy to get some more details on how it “should” work.
Looking forward.

If it is of interest, I can attach a the trace too.

I use the homatic binding with open hab to control my homatic devices (BIDCOS). I se no CCU for this i user homegear (https://www.homegear.eu) on a Raspberry Pi. It works perfect for me. And with in homegear nightlys are some new modules like Sonsos, Philips Hue (testing ist at the moment) and …

Sh… i did not read correct it was not Homematic IP it was Homematic wired. soory for that. But i am sure thet homematic IP will come soner or later.


I’m using a couple of classic Homematic thermostats (HM-CC-RT-DN) and just installed by first Homematic-IP thermostat (HMIP-eTRV). It’s working fine with Homematic CCU2 latest version 2.17.14 but not with OH.
I’m wondering whether the OH binding for Homematic will be amended so that it works with Homematic-IP as well?




that’s a problem for future firmware updates from now.
While the HomeMatic / Homegear Binding is not supporting Firmware 2.17.xx and higher, we need to keep at maximum 2.15.X

Is there any change planned?

I tried it today and it definetly is not working on 2.17.14 - Please do not update if you want to use openHAB with Homematic!


Ouuuh, i really was to fast in writing.

Good news: I upgraded to 2.17.15 which is available since one or two hours and this is working again ! :slight_smile:

I will try to add homematic IP devices the next days. This looks great.


2.17.15 is working for Homematic-IT thermostats with CCU2.

It does not work with OH Homematic binding:
Number nuRadiatorIstTemp “Wohnzimmer [%.1f °C]” (Radiator) {homematic=“address=add SGTIN here, channel=4, parameter=ACTUAL_TEMPERATURE”}

Either the homematic binding string is incorret or the binding does not support IP-devices.


To my understanding Homematic IP is using a protocol the current HM Binding does not (yet) support.
The classic Homematic offers an BinRPC and an XMLRPC Interface and the HM Binding only supports BinRPC.
The new Homematic IP Devices are only available on the XMLRPC Interface (and another Port) and therefore not supported in the HM Binding.

Hi since I am only in Zwave currently … Sorry for a Newbie question.

Is there something like a USB Dongle I can use to talk from openhab (raspi) to HomeMatic ip Devices or is the ccu Central unit a must ?

In addition to CCU2 (which has been enabled to speak to HM-IP devices) there is a so called “OCCU-SDK Kit” which can be installed on an Raspi. You need as well a CUL in order to talk to HM or HM-IP devices via 868 MHz.
I use the CCU2 only as hub to/from HM and now HM-IP devices. Does any plan / idea exist as of when the OH binding will support HM-IP devices as well? I’m happy to help but probably can’t support coding activities.


Hi Homematic IP Users!

I’ve implemented XML-RPC for Homematic IP. Because i don’t have a HM-IP device yet, i need your help. Can you please test this version of the binding and give some feedback? CCU2 firmware >= 2.17.14 required for HM-IP.

The XML-RPC communication works for me, but i don’t know if the metadata fetching at startup is working correctly for HM-IP devices. Maybe someone with at least one HM-IP device can start the binding in TRACE mode (see wiki) and send me the full log. If you don’t want to make the logfile public, you can send me a mail to.


Hello Gehard,

thank you very much - i’m a partner of eQ-3 for implementing smart home systems and i’ll request for some HM IP-Devices to evaluate it.

I’ll contact you as soon as possible.

Is it also possible to use the new HomeMatic IP Gateway or is it CCU2 only?


Hi Marco,

the 1.x binding is CCU only, the 2.x binding will be 100% Homematic-API compliant and should work if the Homematic IP Gateway supports the required methods. I’ll try it when I get one.


was very busy last week and wasn’t able to give it a real try until now. I will look further during easter weekend.
On my short test i wasn’t able to install the new module as i was unable to remove the existing one (existing one is running but not showing as installed in paperui, new one in /addons folder couldn’t load as the old one was already running i guess).
Will update you during the next days…

HM IP Communication is working fine for me with the new binding. - Thank you very much!
I only have two HM IP Devices and both Thermostats are reporting the temperatures without problems.

Will send you a trace next days…


Great! I’ve already received a trace from Rainer, metadata looks good, so the current status:

Metadata: confirmed
Receiving values: confirmed
Sending values: pending

Can you confirm, that sending values to a device is also working?

seems unfunctional at the moment:

2016-03-25 12:10:06.642 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Kinderzimmer_Temp_Set’ received command 22.0
2016-03-25 12:10:06.643 [ERROR] [l.communicator.HomematicCommunicator] - null sending (<?xml version="1.0" encoding="ISO-8859-1"?>setValue000393C98XXXXXD:1SET_POINT_TEMPERATURE22.0)
org.openhab.binding.homematic.internal.communicator.client.HomematicClientException: null sending (<?xml version="1.0" encoding="ISO-8859-1"?>setValue000393C98XXXXX:1SET_POINT_TEMPERATURE22.0)
at org.openhab.binding.homematic.internal.communicator.client.XmlRpcClient.sendMessage(XmlRpcClient.java:111)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.client.BinRpcClient.setDatapointValue(BinRpcClient.java:175)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.client.BaseHomematicClient.setDatapointValue(BaseHomematicClient.java:72)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.client.CcuClient.setDatapointValue(CcuClient.java:232)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.HomematicPublisher.sendToClient(HomematicPublisher.java:79)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.HomematicPublisher.execute(HomematicPublisher.java:65)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.HomematicCommunicator.publishToHomematicServer(HomematicCommunicator.java:323)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.HomematicCommunicator.receiveType(HomematicCommunicator.java:284)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.communicator.HomematicCommunicator.receiveCommand(HomematicCommunicator.java:251)[10:org.openhab.binding.homematic:]
at org.openhab.binding.homematic.internal.bus.HomematicBinding.internalReceiveCommand(HomematicBinding.java:176)[10:org.openhab.binding.homematic:]
at org.openhab.core.binding.AbstractBinding.receiveCommand(AbstractBinding.java:97)[144:org.openhab.core.compat1x:]
at org.openhab.core.events.AbstractEventSubscriber.handleEvent(AbstractEventSubscriber.java:42)[144:org.openhab.core.compat1x:]
at org.apache.felix.eventadmin.impl.handler.EventHandlerProxy.sendEvent(EventHandlerProxy.java:415)[3:org.apache.karaf.services.eventadmin:4.0.3]
at org.apache.felix.eventadmin.impl.tasks.HandlerTask.run(HandlerTask.java:90)[3:org.apache.karaf.services.eventadmin:4.0.3]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_65]
at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_65]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_65]
at java.lang.Thread.run(Thread.java:745)[:1.8.0_65]
Caused by: java.lang.NullPointerException
at org.openhab.binding.homematic.internal.communicator.client.XmlRpcClient.sendMessage(XmlRpcClient.java:85)[10:org.openhab.binding.homematic:]
… 18 more

I just ordered a HM-IP device. I’ll let you know in this thread when it works.

It’s now working with Homematic classic and IP devices. I can receive and set the temperature, set the manual / auto mode etc. Use min. version 1.8.2 of OpenHab.
Thanks to Gerhard who provided an updated version.