Homematic Switch actuator

Hallo everybody,

I just installe a new Switch Actuator from HomeMatic (HM-LC-Sw4-WM).
I saw that in the device setup, I can choose different functions for the actuators. Like to be just a ON or a OFF switch and also the possibility to make ON or OFF impulse for the desired time.
So I thought that could set up one channel to be a Button, and this what i did, in order to command my light Pulse Relais (ON/OFF).
But I cannot make it work via Openhab, no matter what are the Homematic parameters.

this is my approach:

Switch Relais4 “Lights” <“switch”> { homematic=“address=MEQ04XXXXX, channel=4, parameter=STATE” }

(if I use the “autoupdate=false,” the switch will not work! I do not know why)

Switch item=Relais4 label=“Lights” mappings=[ON=“GO”]

What happens it that the switch turns the actuator ON but does not go back to the OFF state after.

Is there something else I have to do?

Take a look at the switch syntax in the wiki:

itemtype itemname ["labeltext"] [<iconname>] [(group1, group2, ...)] [{bindingconfig}]

So your item needs to be:
Switch Relais4 "Lights" <switch> { homematic="address=MEQ04XXXXX, channel=4, parameter=STATE" }
You have a wrong syntax for the iconname. That could be the problem in your case.

I tried to change as you suggested, but with the same result.

if I check the log this is what I get:

21:55:16.042 [INFO ] [runtime.busevents :22 ] - Relais4 received command ON
21:55:17.302 [INFO ] [runtime.busevents :22 ] - Relais4 received command ON

But the switch does not make the cycle at all.
As if the command to the CCU does not go.

Actually the only way I was able to make the switch behave as a Push button is with a rule on a normal switch.

rule PushButton
Item Relais4 received command