Homematic thermostat changes temperature arbitrarily

Hey everyone,
I have an Openhab2 setup at home, running on a RP3, a Homematic CCU2 unit and 3 Homematic thermostats connected to it. I have a couple of rules, which are applied via Jython (JSR12235 or whatsitcalled), which control the heating through window sensors and some self-defined buttons in the UI.
A couple of days ago, without any update/change of the system in advance, that would explain it, one thermostat sometimes arbitrarily switched its set temperature to 12*C, later another one showed this behaviour as well, but less often. This happened so far 2-3 times per day and it seems to reset to the previous temperature automatically after about 15 minutes.
I was concerned, that I might have a security breach, so I updated my software and checked/set some better configurations for the RPi and the CCU2, but the behaviour is still there. Also, the logs don’t show any event, that would explain the change, only the set event itself:

2021-01-13 16:45:07.046 [vent.ItemStateChangedEvent] - homematic_HM_CC_RT_DN_ccu2_OEQxxxxxxxx_4_SET_TEMPERATURE changed from 18.00 °C to 12.00 °C

Did anyone witness such a behaviour or could explain the origin?
What is especially weird to me is the fact, that it’s consistently setting 12*C, and none of my temperature configurations are set to this value…

I still haven’t been able to pin-point the problem, but my current working hypothesis is, that the thermostats might react to the current cold and the rather poor isolation in the rooms. If I understood it correctly, the homematic thermostats have a built-in ‘open-window’ detection based on temperature (obviously). I will investigate further in that direction and try to disable that ‘feature’…

I (finally, late enough) checked the printed version of the thermostat and, surprise (!), it was actually the built-in ‘open-window’ detection. It can only be activated via Homematic’s webUI. The UI is bad, to put it politely. So, for those who come after me: You find the settings here:

  1. Select the menu point “Settings” on the landing page.
  2. Click “Devices” on the drop-down menu.
  3. In the upcoming device list, pick the thermostat of your choice and click on the “set” button in the right-most column.
  4. In the settings menu find the field “Mode for temperature fall detection” (just use ctlr+f).
  5. Set it to “Inactive”.
  6. Repeat for all required thermostats.