Homematic things are online but some chanels are not updating

After having big problems with the binding and restoring the system some chanels are not updating. There states are stalled. I have to unlink and link them again to update the states. For example I can change the set temparature of a wall thermostate in openhab but a manual change on the thermostate or in the CCU3 is not transfered to OH.
Any idea what could cause this?
I am using OH 3.4
The problems before are described here: Homematic Binding ERROR:Bridge for all IP Things - #6 by Cplant

Hi @rqxrqx,

I also have this behaviour for the most of my devices after each restart of my OH on RPi.
I am using a RPi based CCU3 from ELV with Raspberrymatic if this is interesting here.

Commands can be sent from OH to the CCU, but no status is read back from the CCU to OH.
I had this throughout all 3.x versions of OH and currently I am on 3.4.0 release build.

It is not comfortable but for me it can be solved by disabling and enabling again the homematic bridge Thing after a restart of the OH system has been necessary (e.g. due to a shutdown after a power outage). After that all devices will be initialised again and the system works as expected.


Thank you for the hint. Resetting the bridge works for me to. Although the workaround is very unsatisfying.
Maybee someone can look at the problem!

In the log file I found the homematic related warning:

2022-12-29 09:16:50.706 [WARN ] [ternal.handler.HomematicThingHandler] - Value for datapoint HmDatapoint[name=CONF_BUTTON_TIME,value=255,defaultValue=255,type=INTEGER,minValue=1,maxValue=254,options=null,readOnly=false,readable=true,unit=minutes,description=CONF_BUTTON_TIME,info=null,paramsetType=MASTER,virtual=false,trigger=false] is outside of valid range, using default value for config.

Does anyone know what could cause this warning?

is there any solution on that?
Because I am facing the same problem: Values are transferred from OH to Homematic, but not vice versa.

Unfortunately for me also the workararound of disabling/enabling the bridge doesnt help. It only leads to the values being updated once. After that, they stay the same again all the time.
Is there any “update afer x seconds” trigger that can be set somewhere?

edit: Ok, I “solved” it by setting a rule for the channel “GATEWAYEXTRAS_Reload_All_From_Gateway” to trigger every minute. At least it works now. But still strange that the values are not updated without forcing it.

I trigger the the “Reload_All_From_Gateway” every hour.
It works a while, sometimes a month, but still once in a while items stall.
Sometimes it helps to set the thing satus to which the item is linked offline and online again. But sometimes I have to unlink the item and link it again. In the worst case I had to delete the thing and redefine it.
This is very unsatisfactoryly!
It seems like an binding error. I can’t find any hint in the log files. I have 37 homematic things. Maybee thats too much for the binding.