Honeywell Fan Control Switch

I have a Honeywell fan control switch,
I can’t get it to pair. I thought I read where these will work with OpenHab. Can anyone help me on this?


I was able to get it to add, but it’s not recognized, here’s the info:

zwave_class_basic ROUTING_SLAVE
zwave_class_generic MULTILEVEL_SWITCH
zwave_frequent false
zwave_version 5.23
zwave_listening false
zwave_plus_devicetype UNKNOWN_TYPE
zwave_deviceid 12593
zwave_nodeid 7
zwave_routing false
zwave_beaming false
zwave_class_specific SPECIFIC_TYPE_FAN_SWITCH
zwave_manufacturer 57
zwave_devicetype 18756

What are my options on this?

Check if your device type and id are the same:

If not those may need to be added to the database.

Yes, they look to be the same…


Now what?

Looks good.
No you need to tell us on which zwave binding version you are. If it is too old you need to switch to a recent one. If it is a recent one, you need to reinitialize the device.

Sorry, but how do I tell what version? I started on this about 3 weeks ago and I started with the latest at the time, but I can get you the version if you tell me where to look.

I did try to heal and also reinitialize the device yesterday. Maybe I didn’t do it correctly, is there a procedure for doing it?

Log into karaf and type bundle:list

Should be okay.

Delete the thing and readd it.

But to be honest: it is showing the manufacturer, the device type and the device id: so what is missing? I guess the thing is also “online”?
Do you see any available channels for that device?

I deleted and added 3 times yesterday.

This is what I see…

I had the same issue with a motion sensor the other day. I ended up putting the sensor in test mode so it would be chatty, then it finally added correctly.

I’m not at home, so I don’t know how to use console remotely, I can do that later, unless there is another way to get version.

Oh, I see no channels…

I have removed and added 5 times. Each time it adds, but isn’t recognized. Is there anything I can try? This is a fan control switch, the last few times I added I had the fan running and it added very quickly, but still not recognized.

I went and bought a GE switch, which I believe is made by the same people (Jasco). I had trouble pairing it as well, but I finally got it. Originally, it said not recognized too, then a few minutes went by and the status changed. I believe there is something wrong, but I don’t know enough about this stuff to troubleshoot. Is there anyone I can contact to help, perhaps someone on this forum?

Also, there is only one channel, dimmer 0-100%, but on the switch I can turn on/off and dimmer (by holding). Is there a way I can create an item and then link it set 0% for off and then the last state? Or, should I have more channels and this is just another problem I’m having?

You need to describe how you are doing the inclusion.
The recommend way: open HABmin, hit the plus sign to put the controller into inclusion mode, hit the inclusion button on your device. The device should be near to the controller.
If it is a mains powered device it normally is recognized within seconds, if it is a battery operated device you need to manually wake it up, probably several times (check your manual how to wake devices up).

If you have problems switch the logging of the zwave binding to DEBUG and feed the log through the log viewer to see what is going on.

This is a basic openHAB question, you really need to study the docs.
You can add more than one Item to your channels. In this case you would bind a Switch Itemtype and a Dimmer Itemtype to the same channel, which gives you ON/OFF for the switch and 0-100% for the dimmer.

That’s exactly how I have done in the past and how I was trying. I just installed a dimmer switch and the thing didn’t add using this procedure. I tried several times. The way it finally added was Paper UI, things, hit plus, select z wave, then go to button and depress up or down (which is manufacturers procedure for adding). It was found but wasn’t recognized. As with the fan control, after a few seconds it was.

I will try doing the logging as you described. I really want to like OpenHab but it dang sure is frustrating. However, SmartThings was easy to setup, it just never worked it, so at least I’m better off.

Just got around to trying this, while it does work, it is very clunky as one item doesn’t update the other. Example, if I move the slider for speed and the fan is off, it will turn on. However, the discrete switch doesn’t change states… and vice versa. So, not so basic…