Honeywell TH8320ZW thermostat setpoint not working

I have a Honeywell TH8320ZW z-wave thermostat. Mode control and fan control are working fine. Temp sensor is working fine. But the heating and cooling setpoints I can’t get to work. Information on it is here:

The setpoints are Number:Temperature types. Whenever I change them in OpenHab, the thermostat can’t handle it and just maxes itself out at 99 degrees. As if the value OpenHab is sending it is not valid or too high. Could the thermostat require integer numbers rather than decimals? I’m sending 72.0 or 75.0, no fractions of numbers. But perhaps it’s the decimal? I don’t know. Suggestions?

Number:Temperature tstat_setpoint_cool "Cooling Setpoint" <temperature> (g_tstat) {channel="zwave:device:512:node44:thermostat_setpoint_cooling"}
Number:Temperature tstat_setpoint_heat "Heating Setpoint" <temperature> (g_tstat) {channel="zwave:device:512:node44:thermostat_setpoint_heating"}

Have you tried Number types instead of Number:Temperature?

Yes. Same result.

It was just a shot in the dark. I don’t know zwave at all. Maybe someone else will be able to help, Sorry