Hostname with port 8080 does not work after a while

hostname:8080 does not work
ipadress:8080 works fine
hostname:9001 works fine

after a reboot everything is ok.

Can you ping hostname from a command window?

I have issues with my hostname also. It works in chrome but not safari. It used to work then quit one day. I am thinking it is some type of dns issue. I just have not been able to track it down so I bookmarked the ip.

A few questions do you have the ip assigned as static in your router?
Is your openhab server named with a domain on the end like openhab.local?

As a long term solution, I am going to try setting up my own dns server and have my router send that out over dhcp. I am looking at this as it should permanently resolv issues like this.

1 Like

Have you looked at pi hole? I use an older RPI 2 and pi hole for a dns server, works good for me. Pi hole also works good to block ads, I have added a switch in OH to turn on/off add blocking when needed. The pi hole is located in a separate room with zigbee and bluetooth dongles attached for extending the range.:smiley:

@H102 just started with pinhole yesterday. So familiar but just getting started.

Love more info on the turning ads on and off when I make it that far. Will be a week or so before I am ready for that.

Its a nice feature and not hard to add.:sunglasses: The correct icon size was the biggest pain for me.

1 Like

@Thedannymullen took a minuet to find but here is the guide for setting up pi hole to work with OH.

1 Like

the openhab server ip adress is static
no domain like openhab.local
hostname is pingable when not reachable from browser
i am using firefox

ok thanks for the tip with different browsers, it works fine on chrome and internet explorer. i wonder why hostname:9001 works fine even when hostname:8080 does not.

after restarting firefox it works again

I agree with everything you just said. I also have times when one of my raspberry pod will respond with hostname and the other not. I wish I could explain, I have just learned to use the IP address.

I know that is not the best answer but it does work so I go with it. I know the more permanent solution will be install a true dns server. Today I started that path installing pihole.