How do I amend the wake-up value of a zwave thermostat?

Hey guys, i’m using config files in my setup which is on OH 3.2.0

For my zwave thermostat (zwave:horstmann_hrt4zw_00_000), how do i configure the wake-up value? its currently set to 256 seconds and is eating through batteries at an alarming rate. I want to amend this to 900 seconds, but not sure how to do that in the confirm files - I’m guessing it a Thing parameter?


I do not know about config files (use UI), but from the UI code tab I get this this: Maybe that will help.


That’s one of the things that is not supported in .things files. You’ll have to do this through a managed Thing (i.e. accepted from the Inbox in MainUI). Then there will be an options to set the configuration parameters like that in the Things’s settings.

1 Like

thanks guys.

Can I have 2 things for the same device? One via the things and the other created via UI?

Or do I need to delete or disable the file based thing

I don’t know the answer to that and suspect the answer depends on the binding. Given what little I know about the Zwave binding I’d expect you’d have to delete the file based Thing first. I doubt it can handle two Things pointing at the same device since the node ID would be the same and I think the node ID is how the binding uniquely identifies the device. Having it defined in both places will probably result in one taking precedence or something throwing an error.

In general it’s not a good idea to mix text based and file based like that.

I doubt having two Z-Wave things for the same physical device will work as the thing is related to the Z-Wave nodeID - it is likely things will get messed up (if it is even possible to save this.)

1 Like