How Do I Set Up A Z-Wave Dead Bolt Lock

Tags: #<Tag:0x00007f7459f529e8>
  • Platform information: RPi
    • Hardware: _ AEOTEC Stick
    • OS: _what OS is used and which version_What ever Openhabian installed
    • Java Runtime Environment: _which java platform is used and what version_What ever Openhabian installed
    • openHAB version: 2.xx

I am at a total loss at trying to set up my z-wave dead bolt lock. I have been trying to get something working…anything working for the last three days.
I just can’t seem to come up with the correct item definitions.
The lock is a 914TPL Touchpad Electronic Deadbolt.
I have Included it successfully many times. Node7
I have been through all combinations of:
https://www.cd-jackson.com/index.php/openhab/habmin/10-habmin-zwave-binding-initialisation
that I can possibly think of and can’t get the simplest Battery Level or Lock_Status to work.
I have tried many versions of the item like:
Number zwave_device_fe40ab17_node7_battery_level “Lock battery State [%d%%]” {channel=“zwave:device:fe40ab17:node7:battery_level”}

None of the variations I can think up will get a valid battery level or door lock state.
The log is full of "Cannot retrieve item “Lock_Battery” or “Lock_Status”.
I have read and reread the OpenHAB Items documentation combing it for some indication of what I am doing wrong and just can’t ferret out the right way to do it.

In addition, the “Overview” of the thing lists a whole lot of alarm types and levels. I can’t figure out how to access those alarms.

I know there must be some explanation somewhere but I just can’t find it.

Can anyone help?

openHAB version: 2.xx

What version are you running?

It’s battery-level, not battery_level.
Just look into PaperUI, it will tell you the correct naming of the channels.

grafik

Could you please post your device type and id from your xml file?

We need to check if it is in the database (even if you included it successfully):

1 Like

openHAB 2.4.0-1 (Release Build)

Well, that is a wack between the eyes for me. I wasn’t using PaperUI, I was going down the steps directed by HABmin. When I couldn’t see any new items I started adding them to home.items. I tried all combinations of “-”, “_”, “batterylevel” etc etc etc. This “bad” one just happened to be the one I was testing when I made the post.
Now I’m finding I have multiple “lock batteries” floating around my items and sitemaps. Time to do some house cleaning. The PaperUI route seems the most direct and with less baggage floating along.
Thank You very much.

Could you please post your device type and id from your xml file?

We need to check if it is in the database (even if you included it successfully):

I’m not ignoring you. I can’t figure out how to find the XML file. Still searching.

In the zwave directory in userdata there should be an xml file for every zwave node.

The location of userdata varies, depending on the OS and how OH was installed.

I did find one for node 7. It seems to be totally generic.
Oops, there was two points where I spotted security codes for the lock.
I edited them out and attached the file.
But except for those security codes I can’t see anything specific for my device.

network_c3fe5936__node_7.xml (18.1 KB)

Not really

  <manufacturer>0x90</manufacturer>
  <deviceId>0x1</deviceId>
  <deviceType>0x1</deviceType>

That identifies the specific device

EDIT:

We identify it as a 914TRL here. It was last updated after 2.4 was released. You probably should update the zwave binding using the script. Then delete & re-discover the Thing.

Thank you.
I will do as you advise but first I will try to understand the link to the script. To often I find myself blindly following some thread and it results in problems for me.
But I am pretty sure that won’t be the case this time.

Also, the 914TRL link matches what HABmin shows for Node7. But my keypad is different. Is that something I should put in the comments for the 914TRL…assuming I get things working?

Sometimes the manufacturer uses a different model number when the only difference is appearance. Also, sometimes new features are added with new versions of firmware. We are not aware of any functional differences in this instance.

Thanks everyone. I seem to be off and running. It seems I got off on the HABmin route and didn’t realize that the codes I needed were the “zwave:device:fe40ab17:node7:battery_level” strings. I stumbled into using mangled versions of them because I was trying to copy functions that my Z-Wave thermostat was using.

Frankly I would prefer to not use HABmin but I can’t figure out how to use the extra functionality without HABmin. For example, the 914TRL page lists “ApplicationNote-UsingASCII-Z-Wave-Locks.pdf”. There are 8 “Function Numbers” allowing setup of separate lock codes for up to 30 people, ways to schedule the lock codes, etc. Is it that the methods are not known?
Maybe I have a unique situation. I have this lock because it was already installed in the house I bought last year. It is connected to a very expensive security system, They tried to rip me off to transfer the service from the previous owners so I dumped them. I am gradually replacing the previous functionality with openHAB and my own software. I would like to replicate the previous lock functionality as shown in the image:

If there are still unknowns as far as openHAB community is concerned, I can exclude the lock from openHAB and include it back to the security controller and see what can be learned. Would that be useful? Would it be necessary if the extra functionality is understood already?

Well, the update using the script was a dismal failure for me. I’m pretty new to Linux but I think I did the download correctly. The instructions repeatedly refer to zzManualInstall.sh but I have no such file. I did use openhabian so I tried:

If using a package installation (like openHABian), execute the script with sudo -E -u openhab bash zzManualInstaller.sh.
That got me “No matching bundles…normal if a binding had not been previously installed”…but I have been using the zwave binding?
Then:
"It has taken more then 2 minutes to uninstall the Z-Wave binding, so exiting"

There is a section:
Here are the steps this script performs, and which you could choose to do manually
which I tried but I just get recurring command not found and I seemed to be going further astray.

I just rebooted and it doesn’t seem like I killed anything with all my stumbles.

Do I really need to update the z-wave binding?

If you want support for your device you can either update the binding or update to OpenHAB 2.5M3. I assumed you did not want to run a testing version of OH.

Well, now I understand a little better. I am in a state where I have bare minimal functionality from the door lock. Nothing like what I had when it was connected to the security system. But my thermostat is nearly fully functional and I have a few more devices that I need to integrate (CO detectors, switches). So I think I should move on to them and other things until the next update. If it takes too long I’ll try 2.5M3.1. I am not afraid to try a testing version.

Thanks for the help.