How to access openhabian.conf via Windows 10

Hello Community,

I installed openHABian on my Raspberry Pi 4 and connected it through Ethernet to my home network. Afterwards I tried to connect the Pi via Wifi by changing the openhabian.conf. But unfortunately, it changed nothing. According to the Topic: Setup Wifi after first boot by Fox27, I also reinstalled everything. But my problem now is, that I have no clue how a access the openhabian.conf. If I go to the SD directory, I see only a folder named overlays and a lot of other files. Non of them is the config file. Also it doesn’t looks in general like a OS system. Windows is also only seeing an 250 MB big SD card. So I have to access to perhaps the real directories. What can I do, which tool could I use?

Thanks in advance!

What about the totally outdated habit of reading the docs ?
If you deleted the file, you can copy it from /opt/openhabian/openhabian.conf.dist

Thank you very much for your helpful reply mstormi! If it would be that easy, I would not ask for help. As I already explained, the directory of the SD looks completely different on Windows. For a better understanding on you side, please have a look on the screenshot. You can clearly see, that there is nothing that looks like the familiar Linux OS directory. So the question now is, how can I access the well known Linux directory?


Read the docs again to understand it right.
It is a Windows directory, and if you were to scroll down you should see openhabian.conf, too.

I noted the steps during my re-installation, hopefully it solve the issue:

  • Download openhab image-file via the openhabian site (
  • Use “etcher” to burn the image file onto the SD-Card.
  • Flash the system image to your micro SD card as described, do not remove the SD card yet
  • Access the first SD card partition from the file explorer of your choice (e.g. Windows file explorer)
  • Open the file openhabian.conf in a text editor
  • Uncomment and fill in wifi_ssid=“My Wi-Fi SSID” and wifi_psk=“password123”
  • Change the password
  • Change the country-code
  • Change timezone
  • Save, Unmount/eject
  • Put the SD-Card in the Raspberry, connect the internetvamble to the router and put the power on. Now wait for 3 hours to let the system install it all.
  • Use Putty to connect to the raspberry (ip address)

Thanks for your participation on the discussion!
I understand every step on your journey, its quite clear and easy. The only problem I have, is to access the Linux OS partition with Windows. After flashing the SD with Etcher, I tried to find! and change the openhabian.conf with an old Android phone. I found the file this time and changed everything. Than I connected only the power supply to the Pi and checked with openhab/ the status of the installation. But either by this approch nor by checking my FritzBox, it seems that the Pi didn’t connected to the WiFi.
So do I have to connect also the LAN cable?

Thanks for your reply.

I don’t get that, why do you use Android ? It’s dead simple. After flashing, just stop Etcher and access the partition from your Windows file explorer.

Now as we don’t know what you typed in we cannot know if you made a mistake.
Or if you have configured your WiFi to allow for new clients to connect.
(are you sure you accessed the FIRST partition ? As I wrote it is a vfat (FAT-32) Windows file system)

Yes that’s way simpler.
And any Home Automation server should be running wired for sake of reliability anyway.

As I explained several times. Please have a look on the screenshot. This exactly what I can see via Windows file explorer. So please tell me, what I am doing wrong!

No you said you found the file. Your “explanations” are confusing.

Yes with the Android phone, because it is a Linux system, that should be able to read the files. But I am not able to find the file an my Windows computer.

Nonsense, the FIRST partition is a WINDOWS file system :roll_eyes: . If you are you talking about the SECOND partition then you have to state that. If the file on the FIRST partition IS visible from Linux/Android but is missing when you access from windows then you’re failing to properly operate your Windows explorer. If it REALLY isn’t there you can create it, source is here.
Or attach a console and do it inside openHABian.

Personally, I use ‘Bitvise’ on Windows 10, as it gives you an SSH session, and an SCP session. Try this, and then you be able to browse the Linux file system.

There is no need to browse the SECOND partition which has a Linux FS.

Problem fixed. It looks like Etcher made twice an error while flashing the micro SD. So that the openhabian.conf and also other files were missing. Tried it again and now the file is visible under Windows without any problem.