How to add Items to homekit in OH3 using GUI

I using openHAB quiet a while (since 1.3 and I loving it). Right after christmas I setuped oh3 from scratch.
I have spend hours to do the items-config in the GUI (moste Thing-config I did textual).

Today I tryed to add HomeKit but i strugel with. How con I assign a item using GUI to Homekit (as I don’t have any text-file for Items).

Thanks for any hint.

you need to add Metadata to item and use namespace Apple HomeKit

  1. Click on “Add Metadata”

  2. Select “Apple HomeKit” from namespace list

  3. Click on “HomeKit Accessory/Characteristic”

  4. Select Accessory type

1 Like

Perfect. Thanks. Do I have to reboot anything or should the item apear in homekit as soon as I add the meta-data like in OH2. Because I can only see OPENHAB 3 (marked with “not supported”), but no items in homekit.

there was a small issue in OH3.0 release with metadata - changes in metadata have not triggered a homekit refresh. it is fixed in the snapshot version but not in the official release. so, you would probably need to restart

1 Like

Hi All,

Still having the same issue here with “not supported”

Is there anyone who can help me out?

Brgds, GJ

Hi GJ,

“not supported” can have different root causes.
following information would help to narrow down:

  • do you have items with homekit meta data?
  • do you have color temperature (currently not working with homekit)?
  • was it already working before?


Thx for your quick reply!

I added items via the GUI…tried different ones. Brightness and also color.

Should I do more configuration than just selecting the characteristic in the GUI for adding metadata?

Metadata not added for color temperature, but should I delete color temperature from the item? I selected all possibilities when adding items as equipment

It was never working and quite new to openHAB

Many thanks for your help!!

Brgds, GJ

you can keep color temperature item, but dont add homekit meta data.
i would start with one lightning item.
please take look on these steps:

I already did this for lightening.brighness, no other are currently added for metadata.
After your last step, should I do anything more?

The tab “Code” has following:
value: Lighting.Brightness
config: {}

I restarted, deleted the pairings, deleted and added again openhab in homekit app on my phone, but still no results unfortunately

this issue is very probably the missing correctly configured homekit items. what kind of item you use for Lighting.Brightness? Dimmer or Color?

can you try to replace Lighting.Brightness with just Lighting?

I have “Uplight Rechts” (is a milight rgbww light) which is working correcly from the GUI when changing any values

I now have added metadata “Lighting” to item “Uplight Rechts” (lightbulb)
and added metadata “Lighting.Brightness” to item “Brightness” (dimmer)

I’m not sure if I have to do anything (stop start openhab, delete openhab from homekit, delete pairings. What is the correct procedure to follow?

Could it be an issue that OpenHAB is not added as “Bridge” but just as “Accessoiry” in homekit?

it looks like “Uplight rechts” is a group created from the semantic model, correct? I dont think this will work.

just use your Dimmer point item Brightness in the first place.

My Dimmer works with adding the two metadata tags “Lightning, Lightning.Brightness”. Maybe try that combination. If you correctly have installed the homekit binding and you see the openHAB bridge in your homekit, there is no need to restart. The bulb should be visible in a matter of seconds. I am using the EVE app to administer the items in homekit. Is a bit better overview. The lightbulb and bridge will show up in the “STANDARDRAUM” ( German )

if openhab cannot find any item configured for homekit, it will appear in home as accessory. if it has at least one item configured for homekit it will appear as a bridge.

Sorry for the late reply…didn’t have the time to try things out. Indeed the semantic issue you raised seemed to be the problem. It’s working now!! Many thanks!!

Hi all - I’ve been running into a similar issue, and I don’t understand how it’s supposed to work.

From the openhab homekit docs:

If the shorthand version has only a characteristic then it must be a part of a group which has a HomeKit accessory type. You can use openHAB group to define complex accessories. The group item must indicate the HomeKit accessory type, e.g. LeakSensor definition

… and it goes on to show a LeakSensor example where the group has the LeakSensor metadata, but the actual characteristics (?) are on the items within the group.

That’s what I believe GJW was trying to do, and so am I - I have an “Equipment” group for a light and I’ve added the “Lighting” homekit metadata to it. The colour control is an item/Point in that group, and it has homekit metadata “Lighting.Saturation”, “Lighting.Hue” and “Lighting.Brightness”. That results in a single thing being exposed on homekit that however only has an OnCharacteristic - the item is ignored, and only the metadata on the group is honoured/exposed. That seems counter to what the documentation describes?

If I also add “Lighting.OnState” to the item under the group, then both the group and the item get exposed separately, which is also not what I’m looking for.

I’m using openHAB 3.1.0.M2.

the way how you and GJW are describing your configuration, sounds correct to me. The accessory type metadata must be at group, e.g. lighting, the characteristics meta data at items of that group. so, exactly how you describe it.

based on behaviour you see in home apps, it looks like items are not linked to the group and group has no homekit metadata.

can you describe exact steps you do, or maybe screenshots, so that i can reproduce the setup locally on my machine?

Right - I’m configuring most of it through the UI (bar things themselves), so here goes a few screenshots.


Attempt 1

Item, without an OnState characteristic - only Hue, Sat, Brightness


Attempt 2
Item, with an OnState characteristic - so: OnState, Hue, Sat, Brightness