How to bind discovery process to one network

I have an Ubuntu server on which openhab 2.3 is running. It also runs 2 vpns. Openhab locates the Tradfri gateway I have on, but also tries to discover the same gateway on the 2 virtual private networks. This produces the WARN message in the log “Discovered Tradfri gateway doesn’t have an IP address”. This is just annoying, is there any way to stop these messages other than changing the log level? I’m really looking for a way to limit discovery to just the one network.

As far as I can tell that is an option that would need to be implemented by the Binding. If there isn’t such a binding, I don’t know that there is much you can do.

You don’t need to turn down the log level over all. You can filter that one log statement out. OpenHAB - Filtering event logs