How to configure a Netatmo Thermostat?


I read the document for the Netatmo binding, but I wasn’t able to understand how to configure. I have the application created succesfully, but couldn’t create the things or item. I have all the REST response with the data.

Can any of you assist?


You’ve got to install first the Netatmo API bridge, configuring it with your own credentials (username, password, security keys…). Once done, you can go directly to discover thing. Your things and channels will be setup automatically.

Hi Gaël,

I did it, and found problems

2016-12-06 22:20:20.447 [ERROR] [netatmo.handler.NetatmoDeviceHandler] - Exception when trying to update channels: null
2016-12-06 22:20:20.545 [ERROR] [netatmo.handler.NetatmoDeviceHandler] - Exception when trying to update channels: null
2016-12-06 22:20:20.703 [ERROR] [netatmo.handler.NetatmoDeviceHandler] - Exception when trying to update channels: null
2016-12-06 22:20:20.807 [ERROR] [] - Exception occured while informing handler:null
at org.openhab.binding.netatmo.handler.thermostat.NATherm1Handler.getNAThingProperty([194:org.openhab.binding.netatmo:]
at org.openhab.binding.netatmo.handler.AbstractNetatmoThingHandler.updateChannels([194:org.openhab.binding.netatmo:]
at org.openhab.binding.netatmo.handler.AbstractNetatmoThingHandler.handleCommand([194:org.openhab.binding.netatmo:]
at org.openhab.binding.netatmo.handler.NetatmoModuleHandler.handleCommand([194:org.openhab.binding.netatmo:]
at org.openhab.binding.netatmo.handler.thermostat.NATherm1Handler.handleCommand([194:org.openhab.binding.netatmo:]
at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.channelLinked([103:org.eclipse.smarthome.core.thing:]
at org.openhab.binding.netatmo.handler.AbstractNetatmoThingHandler.channelLinked([194:org.openhab.binding.netatmo:]

Any idea?

This issue seems to have appeared with last PR of the binding but does not prevent it to run normally on my side, but it can have an impact on discovery service. Can you create an issue in Github, I’ll figure out to sort this. In the mean time, if discovery fails, you still can create things, items using configuration files (it works for me)

the discover worked, but I don’t have any value, as all it is NULL.

did this issue get solved? I have the same problem.
the discovery worked but I only get some values for the main module, but not for any of the other connected modules.
and the mentioned error message in the log
(using 2.1.0)

kind regards