How to enable UI back?

Hello. I am running openhab on RPi and when I’m typeing it’s ip in the browser, when should I find a screen with chosing UI I have just “Access denied. The action requested is forbidden.”
I think access to it is somehow disabled. Anyone know how to enable it back?
In the logs I see, that paper ui is loading.

Hi @JBr

What port do you have openHAB configured to listen on? I believe the default is 8080. (You can however setup a redirect from port 80 though.) For example, I access my openHAB setup via

Also, what steps did you follow to configure? If you post a link to those steps it may help with the troubleshooting.


I think I may somehow disable access to UI’s, but don’t remember how (because openhab was only used with alexa and homekit). Now, when I type IP with port :8080, the site says " Access denied. The action requested is forbidden."

I reinstalled openhab and also now, when accessing ip through browser it says “Access denied”.
Any ideas?

what exactly do you see in the logs ?

the logs says:

2020-06-19 08:38:43.001 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2020-06-19 08:38:47.692 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-06-19 08:38:47.698 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2020-06-19 08:39:23.988 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
2020-06-19 08:39:25.804 [INFO ] [openhab.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2020-06-19 08:39:26.484 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel

And yet when I try this IP in web browser it says acces denied.

As far as I understand the situation
you get the message

this normally mean the port is open and you are connected but due to access limitations/restrictions like authentication based on IP addresses or not being the right user you will see this message.
In case the port is not open browsers display the message connection refused or connection was reset.
access denied also could mean that due to file system restrictions the web server process is not allowed to access a file.

In case of this specific problem I would go into the karaf console and change the log level for
org.eclipse.jetty to DEBUG level.
This might/will drastically increase the amount of items to be logged.
So make sure that that part of the logging will be changed back after doing the analysis.

There might be other / better ways to continue. For the moment I would do it in this way.

I changed port on which openhab is running to 8081 and surprisingly it worked. I checked if there are another device on this ip/port (8080) but I doesn’t find anything. Don’t know what caused this problem, but at least it solved now. Thanks for your involvement!