How to force Zigbee Initialization

Tags: #<Tag:0x00007fc1f8736ce0> #<Tag:0x00007fc1f8736c18>

System Info:
RP3B+ / OH2.5.0 (stable) / Qivicon Zigbee USB Dongle

Hi all,
maybe you can help me with a little problem: I manage to bind a the Aqara Temp/Humi (square) sensor via the Zigbee binding. Sensor shows ONLINE in Config > Things - but does not deliver any data (NaN) and seems not to be initialized (zigbee_device_initialised false).

What can I do to force initialization? Or is the “no data” issue coming from somewhere else?

Thx & sorry for the noob-questions…

FM

Hallo,

i have the same problem, have you found a soultion?

  • Aqara Temp/Humi/Presure WSDCGQ11LM
  • BV 2010/10 (ZigBee USB dongle), Ember EM35x Coordinator
openhab> bundle:list -s | grep zigbee
279 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee
280 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.console
281 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.console.ember
282 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.dongle.cc2531
283 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.dongle.ember
284 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.dongle.telegesis
285 x Active x  80 x 1.2.9                   x com.zsmartsystems.zigbee.dongle.xbee
286 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee
287 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.cc2531
288 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.console
289 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.console.ember
290 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.ember
291 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.telegesis
292 x Active x  80 x 2.5.1                   x org.openhab.binding.zigbee.xbee
openhab>

image
image

2020-02-14 19:09:47.993 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Configuration received: {zigbee_macaddress=00158D000444C9ED, zigbee_initialise_device=true}
2020-02-14 19:09:47.995 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Configuration update: Ignored zigbee_macaddress as no change
2020-02-14 19:09:47.997 [DEBUG] [.binding.zigbee.internal.ZigBeeDeviceConfigHandler] - Configuration update: Ignored zigbee_macaddress as no change
2020-02-14 19:09:47.999 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing device
2020-02-14 19:09:48.002 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_temperature with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterTemperature@17dbdb86
2020-02-14 19:10:00.003 [DEBUG] [gbee.internal.converter.ZigBeeConverterTemperature] - 00158D000444C9ED: Failed to bind temperature measurement cluster
2020-02-14 19:10:00.005 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterAtmosphericPressure@5ef37dc0
2020-02-14 19:10:12.006 [ERROR] [ernal.converter.ZigBeeConverterAtmosphericPressure] - 00158D000444C9ED: Error 0xffff setting server binding
2020-02-14 19:10:12.007 [INFO ] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure failed to initialise device
2020-02-14 19:10:12.008 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_humidity with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterRelativeHumidity@6f168070
2020-02-14 19:11:59.173 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Configuration received: {zigbee_macaddress=00158D000444C9ED, zigbee_initialise_device=true}
2020-02-14 19:11:59.177 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Configuration update: Ignored zigbee_macaddress as no change
2020-02-14 19:11:59.178 [DEBUG] [.binding.zigbee.internal.ZigBeeDeviceConfigHandler] - Configuration update: Ignored zigbee_macaddress as no change
2020-02-14 19:11:59.180 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing device
2020-02-14 19:11:59.182 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_temperature with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterTemperature@37912285
2020-02-14 19:12:11.183 [DEBUG] [gbee.internal.converter.ZigBeeConverterTemperature] - 00158D000444C9ED: Failed to bind temperature measurement cluster
2020-02-14 19:12:11.185 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterAtmosphericPressure@d923195
2020-02-14 19:12:23.186 [ERROR] [ernal.converter.ZigBeeConverterAtmosphericPressure] - 00158D000444C9ED: Error 0xffff setting server binding
2020-02-14 19:12:23.188 [INFO ] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure failed to initialise device
2020-02-14 19:12:23.189 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Initializing channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_humidity with org.openhab.binding.zigbee.internal.converter.ZigBeeConverterRelativeHumidity@55bff4b4
2020-02-14 19:17:44.818 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA0A047554: Polling...
2020-02-14 19:17:44.819 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA0A047554: Polling zigbee:device:01382872:7cb03eaa0a047554:7CB03EAA0A047554_3_dimmer
2020-02-14 19:31:41.650 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Polling...
2020-02-14 19:31:41.651 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Polling zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_temperature
2020-02-14 19:31:53.653 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Polling zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_humidity
2020-02-14 19:32:05.654 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Polling zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure
2020-02-14 19:33:16.963 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA0A047554: Polling...
2020-02-14 19:33:16.964 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 7CB03EAA0A047554: Polling zigbee:device:01382872:7cb03eaa0a047554:7CB03EAA0A047554_3_dimmer
2020-02-14 19:38:16.999 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Command for channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_temperature --> REFRESH [RefreshType]
2020-02-14 19:38:17.005 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Command for channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_pressure --> REFRESH [RefreshType]
2020-02-14 19:38:17.010 [DEBUG] [.openhab.binding.zigbee.handler.ZigBeeThingHandler] - 00158D000444C9ED: Command for channel zigbee:device:01382872:00158d000444c9ed:00158D000444C9ED_1_humidity --> REFRESH [RefreshType]

If it is a battery operated device it must be woken up. Check your owners manual for how to wake the device. It may take several attempts to complete initialization. Just keep waking it up until it completes