How to get bitron video BV 2010/10 working?

I just bought a Bitron Video zigbee stick. In lsusb it shows as:
P: Vendor=10c4 ProdID=8b34 Rev=01.00
S: Manufacturer=Silicon Labs
S: Product=BV 2010/10

I do not see a tty device for it. There is not ttyUSBx. I use “Ubuntu 20.04.1 LTS” with current updates.
Is there anything special I need to do to get a device for the stick?

I have no answer (yet), but all I wanted to say is hello Chris! :slight_smile: It might be that stick appears as ttyACM device. If you see it in output of lsusb it is rather properly recognized by operating system. Trouble might be how it appears. You can also try to tap dmesg to see what identifier was assigned to it.

1 Like

This device uses custom PID/VIDs - they are not included in all OS’s, although I would have expected it to work in Ubuntu. This is why the device doesn’t work on OS’s such as MacOS - unfortunately.

I assume of course that you’ve read the docs as they do talk about this :slight_smile:

If the usb dongle is not recognized, it might be necessary to make the dongle’s device id known to the CP240x driver by Silicon Labs:

Find the device id (as listed by the command lsusb). For the Bitron Funkstick that might be 10c4 8b34.
Unplug the device
Enter the following commands (replace the id 10c4 8b34 with the one listed by lsusb):
sudo -s
modprobe cp210x
echo 10c4 8b34 > /sys/bus/usb-serial/drivers/cp210x/new_id
Plug in the dongle. It should now be recognized properly as ttyUSBx.

If you’ve not tried this, I suggest to give it a go.


What is the output of dmesg | grep tty That is the list of all tty devices currently recognized by the OS.

This is what I see:
root@odroid64:~# dmesg | grep tty
[ 0.000000] Kernel command line: root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait ro console=ttyS0,115200n8 console=tty0 no_console_suspend hdmimode=1080p60hz m_bpp=32 vout=hdmi net.ifnames=0 elevator=noop disablehpd=true max_freq=1536 maxcpus=4 monitor_onoff=false disableuhs=false mmc_removable=true usbmulticam=false usbhid.quirks=0x0eef:0x0005:0x0004
[ 0.000896] console [tty0] enabled
[ 0.497426] c81004c0.serial: ttyS0 at MMIO 0xc81004c0 (irq = 225, base_baud = 1500000) is a meson_uart
[ 2.216609] console [ttyS0] enabled
[ 2.224555] c11084c0.serial: ttyS1 at MMIO 0xc11084c0 (irq = 58, base_baud = 1500000) is a meson_uart
[ 6.127652] systemd[1]: Created slice system-serial\x2dgetty.slice.

Many thanks. This solved it. I now saw the thing in the inbox and could also bind a plug.
… and now that you pointed it out I also saw that it is indeed nicely documented. :flushed:


Hi Lukasz,
was a long time since we last met. Hope the COVID crisis is soon over.
Chris Jackson gave me the solution. It was just to make the device known to the driver.


Thanks for this. I had the exact same problem on Ubuntu 14.04LTS.