How to get digitalstrom on basicUI working?

Hello,

I did, what you told me to do yesterday, when I got the answer from hmerk

As you see in my log files (the post before your post), the shadeAngel ChanelLinkAddedEvent is added.

But when I try to set the shadeAngel I get still the measage [quote=“peaeater, post:14, topic:12402”]
Command sent to an unknown channel id
[/quote]

You gave me the tip to:

At the moment I do not know how to send a refresh command, but when I send the stop command just after rebooting the system, my shade slider becomes updated. With my shadeAngle slider nothing happens.

If I connect the shadeAngle in my sitemap with an switch I get an On/Off Switch. There is no refresh nor stop option.so I supose the stop of the shade switch also should trigger the shadeAngle to become refreshed.

My shadeAngle is not working at all.

A question: Should the shadeAngle be shown in the PaperUI? I only have the possiblity to see and command the shade.

A question: in the openhab1.1 Binding the item name is not differentiated. Should it be the same in oh2? I used Jal_Kueche for the shade an Jal_Kueche_W for the shadeAngle. I also tried both with the same itemname it didn’t work eather. (I hoped to get something like a doubleparted Slider one part for the shade, one part for the angle)

May be we could clearify the issue better in german than in english.

Hallo peaeater,
ja, wir können das gerne auf Deutsch klären. Der Doppelpost lag daran, dass der Account für die openHAB-Community vorher noch nicht freigeschaltet war.

Das Problem, dass kein Item erstellt wurde, ist nun behoben. Zu sehen ist, dass nun die Befehle an den DeviceHandler weitergeleitet werden. Das Problem was jetzt besteht ist, dass der DeviceHandler keinen ChannelTyp ShadeAngle kennt. Einzige Erklärung, die wir aktuell dafür haben ist, dass Sie nicht die aktuellste Version des Bindings installiert haben, sondern die Version vor dem letzten Update nutzen. In dieser Version gab es diesen Channel noch nicht und daher kann der DeviceHandler die Befehle nicht behandeln.

Dies deutet ebenfalls darauf hin, dass eine veraltete Binding Version installiert ist, da der Channel in der PaperUI angezeigt werden sollte. Daher sollten Sie versuchen das Binding zu aktualisieren.

Da wir lediglich das Binding entwickelt haben und nicht viel mit OH2 zu tun haben, wissen wir leider nicht genau wie openHAB das aktuell mit Binding-Updates regelt. Man kann ein Binding auf jeden Fall deinstallieren und wieder neu installieren, ohne das die Things etc. gelöscht werden. Wir schätzten, dass openHAB bei der Installation in der Online-Version das aktuellste Binding aus dem Netz bezieht. Bei der Offline-Version gehen wir davon aus, dass die Bindings mit dem Server heruntergeladen wurden und lokal bezogen werden. Wenn dem so ist, sollte das Binding mit dem deinstallieren und wieder installieren bei der Online-Version gehen und bei der Offline nicht.

Wir gehen davon aus, dass man nicht die gleichen Namen nutzen sollte. Es müsste das oben genannte Problem sein.

Viele Grüße

Michael und Matthias

Hi guys,

sorry, but as this is an international community, please keep conversation in english.

Danke für die Antwort,

But no I have to continue again in english. [quote=“hmerk, post:18, topic:12402”]
sorry, but as this is an international community, please keep conversation in english.
[/quote]

I checked my version.

My Version is 0.8.0 snapshot.

I installed the online version of openhab2 by downloading the zip file.a few month ago and extraced it to /op/openhab2

wget https://openhab.ci.cloudbees.com/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-online/target/openhab-online-2.0.0-SNAPSHOT.zip

sudo unzip openhab-online-2.0.0-SNAPSHOT.zip -d /opt/openhab2/

I installed a sytemd service

cd /lib/systemd/system
sudo nano openhab.service

since than my openhab2 was running and I started to get my astro binding, weather binding an digitalstrom binding to run.

I supose, I have installed the online version, what do I have to to to update my digitalstrom binding from verrsion0.8.0snapshot to the 0.9.0snapshot (it seems to be the latest one I can find at github)

In paperUI I deinstalled my digitalstrom binding extension. Nothing changed in the version, after reboot, I still only can install the 0.8.0snapshot.

What do I have to do to get an updated digitalstrom binding?

Easiest would be to completely remove your old installation, do a fresh download and install everything from scratch.
There have been some more important changes, so this would give you the most benefit.

Hello thanks for your answer.

I allready assumed that that may solve my problem.

I started to read the documentation

Installation on a Raspberry Pi

I’am wondering if I need to do the tmpfs thing described here under tmpfs on SD card based devices

or not.

I will start now from the scratch again. Let see what happens.

Hello Kai,

I installed oh2 from scratch again. With some litle difficulties I got my digitalstrom server thing running.
The problem was to obtain the applikation token, necessary for the communication between dss-server and oh2-digitalstromserver thing.

You have to enter:

curl https://dss:8080/json/system/requestApplicationToken?applicationName=openHAB -k

The answer follows
{"result":{"applicationToken":"ad85b7d897c7bc5a4f1128eb13j78e9590f4fd932dc0688e71cf1e4ba4131a20"},"ok":true}

someone should mention it in the digitalSTROM Binding -> Discovery

After that, you have to accept the applikation token on the dss-server “System/Zugriffsberechtigung”

No, you don’t have to do this.
Just add your user credentials for a one time login and the binding will get and save the application token.

Well I didn’t know that.

No I’am again there, where I was on sunday.

I have a digitalstrom binding version 0.8.0.b5 (I expected 0.9.0 like in github)

The blind still does not move when I change the shadeAngle. In PaperUI I get the following controls

In BasicUI I have now only that:

The blind can be moved by the UP/Down Switch or Slider
The ShadeAngle Slider can be moved, but nothing happens.
I get the following log

2016-07-26 00:31:57.723 [INFO ] [smarthome.event.ItemCommandEvent    ] - Item 'Jal_Kueche_W' received command 57
2016-07-26 00:31:57.728 [WARN ] [g.digitalstrom.handler.DeviceHandler] - Command sent to an unknown channel id: digitalstrom:GR:303505d7f800182000000a96:3504175fe00000000005932e:shadeAngle

I learned a lot again, but I did not reach the target.

I need a hint again.

PS: After reboot (which still is necessary on my installation to become the rollerhuters in running mode) the Astro Sun loses there values completly. I have to delete and create the astro:sun thing to get values again.

Do I have to install from scratch again? How can I check if I have got the correct versions?

I installed again everything from scratch.

This time I installed the offline version.

Under my first entries in the log I encountered two errors. Are they critical for the system? I followed strictly the installation path of the documentation. (The only difference was: I used

sudo systemctl enable openhab2.service

instead of

sudo systemctl enable openhab2

because this was the suggestion after running

sudo apt-get install openhab2-online

)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1498)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
2016-07-26 08:32:55.774 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': null
2016-07-26 08:33:06.273 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2016-07-26 08:33:07.151 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2016-07-26 08:33:09.338 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /ui
2016-07-26 08:33:17.688 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
2016-07-26 08:33:18.012 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': Error restarting bundles
2016-07-26 08:46:27.573 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /ui
2016-07-26 08:46:28.899 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2016-07-26 08:46:29.235 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2016-07-26 08:46:29.284 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
2016-07-26 08:48:02.325 [INFO ] [smarthome.event.ExtensionEvent      ] - Extension 'binding-astro' has been installed.

Also with the two errors the server is running, so I installed the astro:sun Thing.
Here every step comes online without rebooting the system.

Then I installed the digitalstrom Thing and entered my password. The installation the was running completly automaticaly, WOW. (This is a lot easiery then the other way with the Applikation token. You should mention this step in the documention more obviously)
After that I have the possibility to install my BLIND. I did that. It works, but it keeps in the status intitializing

Here I have to reboot now. This is obviously a strange behaviour.
After the reboot there were no more error entries in the log.
The Blind changes to the status online, after pressing the “STOP” button I get the Value 100%, but the astro binding has no values at all.

The version of the digitalstrom thing is in the offline version

Is this the right one? How can I get a newer one?

What am I doing wrong?

Hello peaeater,

No, this isn’t the right one. It’s the version of the Beta3 release, apparently the installation of new Bindings in the Online version download the Bindings at the state of the release and not the newest as we thought. The right version should be 0.9.0. It’s included in the stable release (snapshot), but we can’t install the snapshot on the raspberry pi, because some index-files can’t be downloaded. We also think that the current snapshot is not usable because we get some errors.
The only idea we have is to update the Binding manually through console commands. That’s the way we did the testing of the Binding.

The console command to update the Binding is:bundle:

update <bundleID>  <path to the binding.jar>

The parth have to be like this format:

“File:///C:/openHAB2Addons/org.eclipse.smarthome.binding.digitalSTROM-09062016-1100.jar”

You get the bundle id with the console command:

bundle:list

And you can get the jar, e.g. if you download the openHAB 2 Beta Snapshot Offline Distro and navigate in the zip to

\runtime\karaf\system\org\eclipse\smarthome\binding\org.eclipse.smarthome.binding.digitalstrom\0.9.0-SNAPSHOT

There is the jar file

org.eclipse.smarthome.binding.digitalstrom-0.9.0-SNAPSHOT.jar

We currently don’t know how to access the openHAB shell on raspberry PI may another community member know how or somebody has an easier solution, too.

Otherwise wait for the next official release, then it should be included.

The problem why you have to reboot the openHAB server is fixed in the new version, too.

Best regards

Michael Ochel and Matthias Siegele

That should be possible through “ssh openhab@localhost -p 8101” pwd is "habopen"
This will give you access to the karaf console.
A discussion describing this can be found here.

Hello,

are you sure about the password?

pi@raspberrypi:~ $ ssh openhab@localhost -p 8101
The authenticity of host '[localhost]:8101 ([127.0.0.1]:8101)' can't be establis                       hed.
RSA key fingerprint is c2:bb:72:35:79:d4:cd:6c:ee:f7:ba:f5:10:8a:30:45.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '[localhost]:8101' (RSA) to the list of known hosts.
Password authentication
Password:
Password authentication
Password:
Password authentication
Password:
openhab@localhost's password:
Permission denied, please try again.
openhab@localhost's password:
Permission denied, please try again.
openhab@localhost's password:
Permission denied (keyboard-interactive,password,publickey).
pi@raspberrypi:~ $


Please see this post.

???

Is the way I did it correct, or completly wrong?
I started a ssh session via putty to the raspberry pi.
There in the bash I entered[quote=“peaeater, post:28, topic:12402”]
ssh openhab@localhost -p 8101
[/quote]

Then I became asked for a password. I entered “habopen”. It didn’t work.
Then I was thinking, that I’am using the apt-get version of oh2, which is not realy new, so pwd change from karaf to habopen may be still not implemented. But with pwd karaf the same happens.

So how can I update to digitalstrom 0.9.0 ?

Currently, with the apt-get version of oh2, you need to use karaf for both the username and password:

ssh karaf@localhost -p 8101

When prompted for password, use “karaf”.

Thanks for that hint,

I think I was to tired to see the obviously.

By the way, do you know, when there will be released the next apt-get version?

I guess you used apt-get to install the latest stable version?
Do you know that there is also an option to try the testing versions.
Info can be found here.

You mean I should try

version based distribution names (2.0.0.b3, 2.0.0, …)

Actual I am using the testing version, which is obviously outdated

The problem for me is where do I get actual version number.

I startet looking at bintray and I think the 2.0.0 b3 is the latest.

Am I right, that you think, that when I try

echo "deb https://dl.bintray.com/openhab/apt-repo2 2.0.0.b3 main" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get upgrade

all the problems I encountered for now are blown away?

I tried an I got

pi@raspberrypi:~ $ echo "deb https://dl.bintray.com/openhab/apt-repo2 2.0.0.b3 main" | sudo tee -a /etc/apt/sources.list
deb https://dl.bintray.com/openhab/apt-repo2 2.0.0.b3 main
pi@raspberrypi:~ $ sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?
pi@raspberrypi:~ $

I changed the command to

echo "deb http://dl.bintray.com/openhab/apt-repo2 2.0.0.b3 main" | sudo tee /etc/apt/sources.list

and voila, the update and upgrade is doing something. After that I will reboot and have a look

It did not work, I still have

Was my way correct?

As I don’t install openHAB via apt-get, I can’t tell.
But you can read this post (and the following) to get further info.