How to include new devices to Zigbee binding

I just bought a POPP ZB-stick and now I am trying to get the first bulb included on zigbee network.
I have used Z-Wave binding for years , and thus I believe I have an idea of the process.
Never the less, I always end up with a “Unknown Device”. Only one time I got the IKEA… instead.
So I am obviously doing something wrong, but i can’t figure it out what it is.
I am running openHAB 3.1 and has tried many times.

  1. I reset the bulb (toggle power six times, confirmed by blinking)
  2. I start a scan
  3. The results says “Unknown Device”

I have log files, and have tried to look into them, but I really don’t see any that is obvious to me.

  • How close to the bulb should I have the ZIgbee coordinator?
  • Any settings I should be aware of in the coordinator?
  • Anything that I have forgotten to do?
  • Is the network build like Z_Wave where it is remembered on the stick?
    zigbee-sample-1.log (721.0 KB)
    zigbee-sample-2.log (504.0 KB)

Any Ideas/suggestions ?

ZigBee is a mesh network, so it needs to be close enough to an active router to have a good RF link.

No - it is remembered by the binding and the coordinator has no knowledge of devices on the network. If you loose the configuration, then the binding will try to rediscover the devices.

The logs show very little is being received from the device, which is why it is unknown. I am not familiar with the POPP stick so I don’t know how compatible this is with the Ikea devices or what firmware it is running.

Thanks for the answer.

That was also my impression from reading the documentation.

The POPP ZB-Stick is based on EFR32MG1 SiLabs chip, 
which is a 2.4-GHz, IEEE 802.15.4/Zigbee microcontroller. 
The POPP ZB-Stick (Zigbee) is preprogrammed with Network 
CoProcessor firmware and provides USB interface through 
CP2102N USB-UART bridge.

I posted a link in the previous thread where there is a link to elelabs firmware. I belive the elelabs stick is the same as this Popp. It certainly look very similar.
What firmware do the stick have now?
That said,I think a old firmware version should not give these failures, so look at interference or other rf problems.
Mybe try a USB extention cable?

Edit: Du you use the correct flow control?

Mine reports 6.0.3. 0 in the thing. It seems that there might be a beder FW available.
I already use an extensions cable.

I just realised that one of my UniFi AP runs on channel 11, so there might be something there.

I assume the AP is a WiFi AP - so this will not be a problem as the channels are totally different.

1 Like

Well, you need to be careful here. There was a major change in Zigbee joining with R22 - I forget when R22 was introduced into the Silabs firmware, but some devices will not work without the new join as it enhanced security. What you will see is devices joining, and then leaving - this means devices get left as unknown devices as they stop responding once they leave.

So, firmware is very, very important - especially with new devices.

1 Like

What USB stick with which firmware do you currently recommend? I’m looking to start using the zigbee binding but want to go with the most stable option from the start. Thanks!

I just performed a firmware upgrade, and I had success in first attempt…
The previous behaviour was pretty much as @chris described above. new behaviour is that it shortly says unknown, and then as parameters is queried (seems to be somewhat the same process as in Z-Wave ?) it says IKEA bulb.
The old firmware was 6.0.3-64, and the new firmware is 6.9.1-214.
I will do some more testing, but for now the case is closed. Thanks for all the help :slight_smile:


Sounds good…

Yes, at the tope level, it’s similar to Z-Wave. The binding creates the “unknown” thing first - just in case it takes some time to query the data as it provides immediate feedback to the user. It then queries a half a dozen attributes to work out what it is, and after this it can give it a name. It then queries more information to work out what channels it supports.

Anyway, glad it’s working, and also really good to see that Popp provide a firmware update for their product.

I have not seen any firmware from Popp.
But Elelabs have published firmware.
The Popp and Elelabs stick looks the same so there might be some rebranding going on.

Here you go:

1 Like

Just for the record:
I learned that the Elelabs Stick existed after the Popp stick was reported working with firmware upgrade published by Elelabs.

@mr_eskildsen oh there it is :slight_smile:
Popp do not point to the firmware published with the Elelabs flash tool.
That might be important
Thank you.