How to include Roborock S6 vaccum cleaner?


i installed the Xiaomi Mi IO Binding in my 3.0.0 setup, which is supposed to support the Roborock S6 cleaner. I have not idea how to add my cleaner though …
I entered my credentials i use for the app (the red roborock app) and scanned for the device, but the binding can’t find it locally or via the cloud. I suspect the binding queries a different cloud, as i am not using a xiaomi account, but specifically a roborock account. I can’t add the cleaner manually because i don’t have the token to communicate with it. Controlled via the app the cleaner works just fine.

Has anyone ideas or hints how i could add my cleaner? Thanks alot!

RTFM :slight_smile: You’ll need to switch to the mihome app in order for the vacuum to work with OH.
If activated via the rockrobo app the communication is different indeed.


I cant use that app, xiaomi doesnt let me create an account. Already mailed their support, no answer … it just says “try later”. The only thing i can use is the roborock app :frowning:

Very odd indeed. Only thing I can suggest is to try to make the account outside of the app (e.g via the Xiaomi web site)
Unfortunately until than your out of luck wrt to controlling it with openhab.

I already tried that, too. To make things even more weird: i once had a working xiaomi home account and was using the app. I didn’t do anything besides using my S6, and on one sunny day my account was gone (i never changed any data in it). I was glad to come up with the roborock app, to be able to use my S6 again.
Do you know if/how the xiaomi and roborock accounts are connected? Can i have both controlling one device?

I have never tried the rockrobo app…
My understanding is that they can’t be used simultaneously.

Thanks for your help, i will try to re-create my xiaomi account then.