How to install Aeon Labs Z-Stick Gen 5 on RPi 3?

I’m planing to buy Aeon Labs Z-Stick Gen 5. And now I wonder, do I need to install any driver/software for the stick on my Raspberry Pi 3 or is the driver included in the OpenHAB 2 installation?

Hi, you don’t need to add any drivers, but it’s smart to check which ports are in use before and after you plug it in to understand the adress for it as you need it later in the setup process. You do this by entering:

ls /dev/tty*

This lists your current ports in use, and you can find the adress by seeing which adress that has come up after plugging it in.

However, somebody else could probably explain the process going from there on the best way to set it up in OH2 (if you should use Habmin or Paper UI etc)


1 Like

Sounds about right. One addition, instead of “seeing which address has come up” you can plug in the stick, then type dmesg. You’ll see log lines of the device being added (including port info) in the last few lines. If you type dmesg -w prior to connecting the stick, you can see these messages appear in real time.

1 Like

Thank you for your help, will do that when I install the stick.

Once again, thank you!

Normaly it is port: /dev/ttyACM0

1 Like

I noticed that the port /dev/ttyACM0 for the USB stick has changed when I disconnect and connect, is there any way to make the USB z-stick to always be port /dev/ttyACM0, to make it sticky to my z-stick and RPi3?

Hey guys, I have the Z-Stick on my hands but i´m way far from knowing WTH I should do with it, any help?

I connected the device and this is the list that is showing:


thanks a lot

I got the same problem.
I’m new to internet things, I bought a raspberry pi3 a Z-Stick Gen 5, and I install openHABian because it seems to be the best tool for managing internet things.
I got exactly the same screen above with /dev/ttyAMA0 but when I go to Paper UI interface / configuration / things and in Z-Wave Serial Controler in port configuration / Serial Port if I type /dev/ttyAMA0 when I quit I receive the message : : OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyACMO does not exist

the stick is blinking blue,orange and red

thanks for the anwer !

I found the solution
stop the raspberry
restart it
without the z-stick
made a dmeg -w
plug the z-stick
made a other dmesg -w
I now I saw the cdc-acm 1-1.2:1.0: ttyACM0: USB ACM device
when back in Paper UI edit the configuration
put /dev/ttyACM0 in serial number
and now it’s online.

I follow Francois instructions but It doesn’t work for me.
After I connected the z-stick, Raspberry restarted automatically. Then I’m in the same stage, nothing info related to USB port in SSH (dmesg).

Any new ideea to move on?

I had the same problem that the posrt changed every startup, so.:grinning:

Oh ja, i had to change the 99 number to a lower number 10

sudo nano /etc/udev/rules.d/99-usb-serial.rules



sudo adduser openhab dialout

By default only dialout users can access rw the /dev/tty

check with permissions and groups:

ls -l /dev/ttyA*

Remember: you are using linux (always check permissions, user running the processes, etc…).

Hi All—

I, too, encountered this issue and followed Francois’ instructions. And similar to his initial report, I was seeing the Z-Stick flash blue, orange, and red. Where my experience differed is that inserting the Z-Stick seemed to freeze the Pi. So I took a whack at changing the order of his instructions, and it worked. I essentially followed what he posted except that I inserted the Z-Stick before plugging the power back into the pi. This did the trick. I was able to do a “dmseg - w” and found the serial number to be the same (ACM0). This allowed me to successfully add the stick as a thing.

Hi all,

for me the same:
everytime when i reboot the /dev/ttyACM0 is gone…
the recovery procedure from Francois Dion helps from time to time or better sometimes
… but in addition: when stop and start the openhab service after the reboot and the recovery of /dev/ttyA…

now it is 2am … the procedur from Francois does not work anymore … ???

i lose zwace devices … so i must say: the last stable build 2.5.4_1 is a nightmare!!! Zwave loading search fpr zw141. No reboot possible - No stop the service…
What does the developer do?
Sorry realy p o … 8 hours trying to recover … :frowning:
Since 2.5 every new build is unstable than the build bevor. 2.4 same … 2.3 was the last i guess that works as expected.
Is it possible to step back to 2.1 or better to 1.9

now it is 2am … the procedur from Francois does not work anymore … ??? :rage: :rage: :rage: :rage: :rage: :rage:

Solution on PI4 : find:

Almost got a “downer” reading this. But then I “)(//(”#&¤(" f*ck no!!! :oops:

So I attached a small mini USB Hub with Power, attached the Aeon labs zw090 z stick gen5 eu and it worked right away.