How to: integrate OH with a Texecom alarm system

I have a Texecom alarm panel with the Texecom SmartCom and I wanted to use that to integrate it into my openhab. I asked Texecom tech support for the documentation and they replied that they no longer offer this information to individuals/DIY installers. You now need to be a professional installer/integration company to get that. They also included a request form where you have to enter your company details, business plan for the integration, …

This sucks.

I’ve just installed an Elite 24 and SmartCom and one of the key reasons for selecting a TexeCom panel was their reported good support to DIYer installers. So yes, this sucks. Having said that, their customer support has so far been very good.

I was thinking it would be good if the panels could send/receive MQTT messages. Seems a more modern way to communicate than either a hardware interface to the Outputs - and there are only 8 of those as standard - or the Com serial protocols.

No doubt TexeCom want a slice of the Home Automation market but I suspect they are too small to dominate and be standard setters, so much better for them to offer an open interface to other HA systems.

PS this is a very useful post even if I will/hope to use the SmartCom

I’ve been looking at the Texecom installer forum and apparently the SmartCom does already speak MQTT… apparently if you use Wintex to connect to the panel via the SmartCom option it all goes through their MQTT broker. It’s just that you can’t use that option since they aren’t willing to release the documentation unless you are a “professional”.

But it’s not all bad… I did manage to get my hands on the old docs mentioned at the top of this topic - so crestron and simple protocols. You can easily establish a TCP connection to the SmartCom and talk to the panel. I managed to get the zone information and keypad display. I am just having some issues deciphering the panel status and arming (I don’t know if it’s possible to part arm the system - except through keypad emulation).

I was thinking of putting this all together into a binding, but I need to do some learning about OH development first… so I need some time to do that.


Hi Dries

I parked this project for a while because I’ve been busy with real work, but I’m pleased to say I’ve got it working (I use the Moxa nPort) to the point that I can control the lights with the Texecom sensors in the room. Not progressed to further testing but will update in due course.

I had made a copy/paste error in the initial config of the UDP receive item. Found the problem after 4 hours of looking! :slight_smile:

Thanks for all your work on this.


Hi @Nanna_Agesen,

Did you use ComIP or the Moxa nPort approach?



Hi @garymq

For integration to Openhab, I use the Moxa approach, but the alarm is still connected to the cloud with ComIP.

Best Nanna

@Dries - Thanks for the great tutorial. I’ve nearly got it working, but feel like I’m failing at the last hurdle.

I’m getting zone and arm/disarm status updates from my Texecom Premier 48, but not getting any response to either the ASTATUS or LSTATUS requests.

If I log into the Moxa nPort (I’m using a DE-311) console, I can see a character count against the Tx line.

I’ve tried to set things up as closely as possible to your great tutorial (DE-311 settings aren’t exactly the same), but somethings going wrong along the way. Any tips really appreciated.



As a follow-on to my post above, I took at look at the UDP packets through Wireshark. All appears to be OK from the Openhab/server side of things, so I think the issue lies either with config of the Nport or Texecom board.

Hi Julian,

Happy to help.

What I don’t really understand from your message is that you are getting arm/disarm status updates, but you are not getting any updates from the ASTATUS message. But a.f.a.i.k, you only get arm/disarm updates after you are sending the ASTATUS message.

Assuming you are not getting arm/disarm status updates:
Have you tried using Wireshark to send the ASTATUS (or LSTATUS) to the Moxa? Are you getting a response then?

Make sure the Moxa accepts these messages (see “Accessible IP Settings”)


Thanks for helping. I get arm/disarm messages - when I arm/disarm the system through transmission of an A0xxx or D0xxx message. I just don’t get any response to the ASTATUS or LSTATUS send commands, which makes me wonder whether they’re getting through

Incidently, I’ve just finished moving Openhab from my Win10 PC (where I was just dipping my toes in) to an Odroid C2 (dedicated to the task). The zone messages etc. are still getting through, but I can’t see anything registered on Wireshark now! Really strange…

The Moxa is an old model - only has a text interface - and doesn’t appear to have any setting along the lines of “Accessible IP settings”.

One basic question - I’ve currently got the ports for incoming/outgoing set to different values (Moxa sends to Openhab server @ 9999, and listens on 9998) Is this OK?



Where is wireshark running? Is that box connected to a switch port (that won’t see traffic for other boxes)?

1 Like

Wireshark is running on my main Windows 10 box. This is connected to a 16 port unmanaged switch, which the Moxa and the Odroid C2 (running OpenHab) are also connected to

I’m not very good on network issues - is there a way to configure Wireshark to see the traffic between the Moxa and Odroid? If not - any tips to help diagnose this would be really appreciated !

It’s the switch you need to configure. Investigate how ethernet switches work to see why wireshark doesn’t work here - this is useful info for the future.

On a managed switch, you’d then find out how to configure a “monitor” port for the wiresharking device to use.
I doubt there is a way to do that with your unmanaged switch though, so that might be the end of that idea.

Thanks. I’ll try moving back to the OpenHab config on my Win10 PC to aid in the debugging then. This is certainly a steep learning curve, but I’m really thankful for all the support on this forum!

OK - have temporarily moved my OH setup back to my Win10 box (, so I can try and see whats going on with Wireshark (which is now working again. @rossko57 - thanks for the explanation)

Wireshark shows the “LSTATUS” command being sent to which is the Moxa Nport, so I can only assume the problem is in the configuration of the Moxa.

I’ve copied a snip of the Moxa config options below. @Dries Was your “a” delimiter in Hex or something else? You’ll see I don’t have options for the delimiter process…


Hi Tallboy,

Below the screenshots of my Moxa settings. They seem to be the same as yours, except for the ports. In your screenshot I see you using 9999 for post sending/receiving. I think that is fine.
My OpenHAB server listens on port 25001 (also mentioned in udp.cfg), my Moxa listens on port 10000.

So maybe check if you are consistent (in your send/receiving items - in udp.cfg - in Moxa).

As you can see in the screenshot, I have defined multiple destination IP addresses, one of them was the IP address of my laptop so I could troubleshoot UDP packages.

I hope this information helps!


I’m still struggling with this - can’t even get the zone updates to work properly now :frowning: I’ve tried taking the Nport out, and routing the com port output back into my PC, so I can see what’s going on (sending UDP packets both directions). It appears to work OK until I add a delimiter. I can only conclude that the lack of a delimiter process step for the DE-311 is scuppering me… If I run it (attached to the Texecom) without a delimiter, I get lots of input, but which I can’t obviously decipher.

Anyone else got any ideas?

A further update on my attempts to work out what’s going on:

  1. I’ve managed to get the zone/user code receipt working again (phew!)
  2. The Texecom ports are OK - can communicate with Wintex through them in both directions
  3. The UART-Serial port cable is also OK

That leaves me with (a) some other setting on the Texecom that is preventing the LSTATUS/ASTATUS commands being received, or something odd in the Moxa Nport express series (vs. the 5110 that everyone else seems to have used)

Tearing my hair out slightly on this…

Hi Julian,
I wish I could have been more helpful… Any chance to swap the Moxa for a 5110?


You’ve already provided lots of help in just writing the tutorial in the first place. Did you know b.t.w. that it appears you can switch back and forth between Creston and simple protocols? There’s some interesting Node-red examples on the Texecom installers forum.

I’m keeping an eye out for a second-hand one - but haven’t seen anything yet. The other option is to go via a ComIP. Anyone tried this - presumably would need to use the tcp protocol in OpenHab rather than udp?