How to read power consumption with Fibaro FGWP102 Wall plug?

energy
wallplug
Tags: #<Tag:0x00007f01455dd048> #<Tag:0x00007f01455dcf08>

(Niclas) #1

Hardware: raspberryPI 3 + Aeon Labs Z-stick gen 2
OS: Linux openHABianPi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l
openHAB version: 2
Issue of the topic: Can’t read meter_watts

I have a Fibaro Wall plug (FGWP102) and I set this up:

default.items
Switch m06_switch “m06 switch” { channel=“zwave:device:f511b9a2:node2:switch_binary” }
Number m06_power “power [%.1f] W” { channel=“zwave:device:f511b9a2:node2:meter_watts” }

default.sitemap
sitemap default label=“Control”
{
Switch item=m06_switch label="M06 Switch"
Text item=m06_power label=“M06 Power [%.1f]”
}

My sitemap in basic UI shows a switch, that works to turn it on and off, but the power meter always shows zero. I have some questions:

  1. What does the label in items do, since I need to write a new one in the sitemap?
  2. How do I get the actual power usage to show up? I tried with and without [%.1f] in the sitemap. I also didn’t get it working with Number in sitemap, so I used Text. I also tried “m06 power [%.1f]” in the items file, but to no avail.

I fiddled with the REST API to see something, but this is all I see:
[
{
“link”: “http://192.168.1.188:8080/rest/items/m06_switch”,
“state”: “ON”,
“type”: “Switch”,
“name”: “m06_switch”,
“label”: “m06 switch”,
“category”: “switch”,
“tags”: [],
“groupNames”: []
},
{
“link”: “http://192.168.1.188:8080/rest/items/m06_power”,
“state”: “NULL”,
“stateDescription”: {
“pattern”: “%.1f”,
“readOnly”: false,
“options”: []
},
“type”: “Number”,
“name”: “m06_power”,
“label”: “power”,
“category”: “poweroutlet”,
“tags”: [],
“groupNames”: []
}
]

Perhaps I’m doing something wrong with the plug so it doesn’t send out the wattage, but I think it should by default.

Thank you in advance!


(Niclas) #2

Wait a minute, now it suddenly shows 3.0. Perhaps there is some delay in the readings, was I to impatient? :slight_smile: However when I shut it off, i expected it to go to 0… still 3.0. weird :slight_smile:


(Niclas) #3

I found the settings to change when it shall update, and default is 80% change in value, which I thing is pretty much. However, when I try to change this in PaperUI, I get 500 Internal server error, and in the logs, it looks like this. Why is this happening?

2018-02-24 01:42:04.643 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at ‘things/zwave:device:f511b9a2:node2/config’

java.lang.ClassCastException: java.math.BigDecimal cannot be cast to java.lang.Integer

at org.openhab.binding.zwave.handler.ZWaveThingHandler.handleConfigurationUpdate(ZWaveThingHandler.java:749) [231:org.openhab.binding.zwave:2.2.0]

at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration(ThingRegistryImpl.java:94) [116:org.eclipse.smarthome.core.thing:0.10.0.b1]

at org.eclipse.smarthome.io.rest.core.internal.thing.ThingResource.updateConfiguration(ThingResource.java:413) [126:org.eclipse.smarthome.io.rest.core:0.10.0.b1]

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:?]

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]

at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]

at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81) [178:org.glassfish.jersey.core.jersey-server:2.22.2]

at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$1.run(AbstractJavaResourceMethodDispatcher.java:144) [178:org.glassfish.jersey.core.jersey-server:2.22.2]

(Niclas) #4

It seems to work when I changed it in Habmin instead…