How to remove things in paper ui from old bindings?

in paper ui i get some old entrys of old bindings in the section “thing”.

There is:

old milight bridge from milight-v1-binding
milight-thing from new miligh binding (created automatically from paper ui - before i made manual thing configuration)
synop analyzer

I removed them several times inside paper ui, but they are still there. How can i remove them completly?

They all have the status “uninitialized” or “removing”.

There is no entry of the old things in any configuration file any more. I removed the synop binding and i configured milight manually - the new thing is shown as “online”.

Any help?

@halloween What has helped me in most cases like this, is (instructions for apt-get install)
stop OH2
delete the tmp and cache files
restart OH2

sudo systemctl stop openhab2.service
sudo rm -r /var/lib/openhab2/tmp/
sudo rm -r /var/lib/openhab2/cache/
sudo systemctl start openhab2.service

Is still there.

Any new ideas?

Is there no config-file which i can edit manually and remove all unnecessary entrys?

I searched all my config files and i found some entrys in:


There i removed the wrong things and made a server reboot. Now i think the old binding informations are gone…

Bad news, the old entrys are still there.

Late answer but I managed to remove my ghost items in the karaf console.

I listed them first:

smarthome:things list|grep xxxxxxxx

(replace xxx with whatever you are looking for)

Then using the name, I removed them by:

rsmarthome:things remove xxxxxxxxxxxxxxxxx

(replace xxx with whatever the name of the ghost item is)



This worked. Thanks. But not very convenient.

1 Like

Maybe it’s an old thread but FYI, I have to mention that @lipp_markus commands works great for me trying to remove old bindings pre-installed through openhabianpi/openHAB-share/openhab2-addons/*.jar

worked for me as well, thanks for posting the solution.

Although, with the new version there is a “Force Removal” button if the thing does not seems to be removed :slight_smile:

1 Like

Is there a way to remove many things with wildcards or by piping commands together in the CLI or does “smarthome:things remove” only support one thing at a time?

The Hue binding on my openHAB installation went berserk after the latest update and it’s a chore to remove all the related things manually in the paperUI while openHAB is stuck in a loop

Thanks for posting the fix. Much appreciated!

I’ll add a couple of extra things for newbies (like myself).

The console can be accessed via “openhab-cli console” at the OS command line. The default openhab password for the console is habopen.

Lastly, a small correction (at least for me):

Maybe it goes without saying, but I believe this is a typo. I believe it should be:

smarthome:things remove xxxxxxxxxxxxxxxxx