How to reset/clear thing discovery cache

  • Platform information:
    • Hardware: OpenHABian on RPi3
    • openHAB version: 2.2-SNAPSHOT

I submitted a bug report for some mis-categorized TRADFRI bulbs a couple of weeks ago. That got fixed no problem, so I updated my OpenHABian installation to run the latest snapshot build to take advantage of the patch.

I had two new IKEA bulbs of the same type still in the package (waiting for the update to get merged) so I added them to the system. However, the old bulbs of the same type are still showing as the wrong “thing” type.

The bulbs should be 0220 devices however, the two bulbs I already had are still showing up as the 0820 non color controllers.

I imagine this is just a caching issue, but I’m not sure where/what to clear. I’ve tried removing them from the jsondb in the userdata folder, but that had no luck. Maybe I did it wrong?

I also tried restarting the openhab2.service and that had no effect as well.


Edit: I’ve tried hitting the trashcan and re-scanning those entries a dozen times. Still shows up wrong.

I know I didn’t provide a lot of time for a response, but I like to tinker!

I did not figure out how to clear the cache, but since the gateway adds devices sequentially, I figured removing the bulbs from the gateway (via IKEA app) and re-adding them would give them a new ID in openhab. I was right! The appeared as “new” things with the correct device type after re-pairing them with the gateway.

However, in the future, if the gateway decides to re-allocate those device IDs, I want the cache to be primed so as to not cause any issues.

So my question still remains, but at least I can turn the lights off w/ openhab now :sunglasses: