How to set zwave properties like wakeup time in in Things file?

Hi all,

I did a basic setup of a zwave USAB stick with one Devolo temperature and humidity sensor yesterday. I am running openHAB 2.2.0-SNAPSHOT in a docker container on my Synology.
After a nightly reboot the controller gets back online but the sensor stays offline until I set it manually into inclusion mode. Once done it goes quickly online.

There are two reasons why I cannot configure it through Paper UI:

  1. As I am running a docker container the configuration is not persistent when done through GUI and I prefer to have it all in the things configuration file to understand whats happening.

  2. When I tried to configure the sensor detected as zwave thing through Paper UI for test purposes, I found that it does not update but the browser receives a small, black notification box in the bottom right showing a “HTTP 500: Server Error” and the properties get not updated …

Hence I prefer setting this via config file but do not know how?

Thanks for any advice

Unfortunately, you can’t configure devices through the things files - only via the UI. If you use text files for defining things, then also you can’t use the UI (this is a limitation in ESH).


thank you for you quick reply. I kindly appreciate your attention.
Ok, understood. I am suspecting that the configuration done via Paper UI ist stored somewhere in the userdata directory tree and when I mount this from the outside of the container then this configuration should be stored persistently as well …

But then I have the issue that when updating the configuration the HTTP 500 Server Error appears in the Paper UI?

Or do you have an idea how I can force the sensor to go online when openHAB boots up?

Yes, it’s stored in the json database folder. However, if you are using things files to configure the thing, then you can’t use PaperUI to configure that thing - the system doesn’t allow it.

I dont know the docker container, but I would have expected it to map out to an external folder for the userdata - otherwise many things probably won’t work. My guess is that your problem is simply that you can’t configure things in a text file, and also then try and configure them in the UI.

You can manually wake it by pressing a button, but really you need to configure the wakeup period. This should be done automatically by the binding when the device is first initialised, so in general you shouldn’t need to change it unless the default time is somehow ‘wrong’.

However, do you really mean “Online” (ie is the device showing offline)? It should always be online after a restart - but it will also show that it’s initialising until after the device has woken up following a binding restart. If it’s offline, then maybe there’s another problem?

I get this status info in the karaf console after the restart:

openhab> smarthome:things list
zwave:serial_zstick:abcd1234 (Type=Bridge, Status=ONLINE, Label=zwave_usbstick, Bridge=null)
zwave:device:abcd1234:node2 (Type=Thing, Status=OFFLINE: Node not found in Z-Wave network, Label=WZ_TEMP_HUMI, Bridge=zwave:serial_zstick:abcd1234)

Then I started the inclusion on the device and after some seconds it was ONLINE.

When I alter the properties of the sensor via Paper UI, I get this message in the browser and the changes are not done:


This error means that the device is not part of the network and it’s unknown by the controller and needs to be re-included.

Ok, did a manual include:

13:33:30.327 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device::node2' changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE
13:33:31.534 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false
13:33:31.537 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE to ONLINE: Node initialising: PING
13:33:31.538 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: PING to ONLINE: Node initialising: DETAILS
13:33:31.539 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: DETAILS to ONLINE: Node initialising: INCLUSION_START
13:33:31.540 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: INCLUSION_START to ONLINE: Node initialising: IDENTIFY_NODE
13:33:31.542 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: IDENTIFY_NODE to ONLINE: Node initialising: MANUFACTURER
13:33:32.495 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: MANUFACTURER to ONLINE: Node initialising: SECURITY_REPORT
13:33:32.496 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: SECURITY_REPORT to ONLINE: Node initialising: APP_VERSION
13:33:32.545 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: APP_VERSION to ONLINE: Node initialising: DISCOVERY_COMPLETE
13:33:32.546 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:abcd1234:node2' changed from ONLINE: Node initialising: DISCOVERY_COMPLETE to ONLINE: Node initialising: VERSION
13:33:32.721 [WARN ] [ol.serialmessage.SendDataMessageClass] - NODE 2: Already processed another send data request for this callback Id, ignoring.
13:33:33.316 [INFO ] [ommandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false
13:33:50.796 [INFO ] [smarthome.event.ItemStateChangedEvent] - WZ_TEMP_HUMI_SensorRelativeHumidity changed from 56.63 to 61.79
13:33:50.798 [INFO ] [smarthome.event.ItemStateChangedEvent] - ZwaveWzHumi changed from 56.63000000000000255795384873636066913604736328125 to 61.79

The last two entries show that the sensor obviously sends data again eventhough it is still in the state of initializing:

openhab> smarthome:things list
zwave:serial_zstick:abcd1234 (Type=Bridge, Status=ONLINE, Label=zwave_usbstick, Bridge=null)
zwave:device:abcd1234:node2 (Type=Thing, Status=ONLINE: Node initialising: VERSION, Label=WZ_TEMP_HUMI, Bridge=zwave:serial_zstick:abcd1234)

Yes - this is normal.

This is the error details of HTTP 500 from the Chrome Browser console:

So even when the node2 is ONLINE, the Paper UI update fails …

found a corresponding entry in openhab.log:

13:40:04.976 [ERROR] [est.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:abcd1234:node2/config' for thing 'zwave:device:abcd1234:node2': null

As said above, if you are defining your things through text files, you can’t use PaperUI to configure them.

Ok will mount userdata from outside the container to keep data and then I will reconfigure zwave completely through Paper UI …

I removed the Zwave.things and items file and reconfigured Z-wave USB Controller and the Devolo device via Paper UI but I got still the same HTTP 500 Error with the same PUT error in the Google Chrome console log.

I found in the forum that there have been others struggeling with Paper UI and such type of error and that it works with habmin … I will activate it and try it via habmin!

It works with habmin!!! ??? So, I am wondering what’s wrong with the Paper UI …
Have now parameters set via habmin …