Howto remove failed/broken Z-Wave Device

I have two Sensitive Strips Guard (11-01-011 Strips-MaZw) which are physically broken and not working anymore. They are still auto discovered by the binding. I tried to remove from the controller, which does not work.

Is there any way I can force remove them from the controller through openHAB?

I am using a Raspberry Pi 3 B+ and an RaZberry Module with the Z-Wave Binding

Thanks for feedback and response.

I have tried to remove these devices through the openHAB UI - no success
I have tried to set them to failed - no success
I have searched the forum and found a procedure for HABmin, which does not exist for OH3

I really appreciate some suggestions. Thanks for that

I do not know that weather it is possible with the binding or not. But you can use this softwer:

Just plug your stick into the PC connect it amd you can remove failed nods from the stick eprom. I suggest also to backup your stick eprom time to time and have a backup one. In case of any malfunction you can change it without recreate the whole network. (back up software is a different one.)

I had to remove recently a ghost device from my RPi with Razberry2 hat.
I installed Z-Way on the Pi:

wget -q -O - | sudo bash

Do not forget to stop OH at first.

Thank you for the hint Christian.

I have done that many month back on openHAB 2 already, which resulted in a bit of a mess. I could fix it by deinstalling Z-Way again, and the system was stable. Upgrade to openHAB 3 caused a few weeks shutdown to figure out how to get openHAB running again.

Now, when I use Z-Way, I think it is important to follow the correct sequence. Is this one correct?

  1. Install Z-Way
wget -q -O - | sudo bash
  1. Stop openHAB Service
sudo systemctl stop openhab.service
  1. Start Z-Way
sudo /etc/init.d/z-way-server start
  1. Do what is necessary using Z-Way (cleanup, backup, upgrade firmware etc.)

  2. Stop Z-Way

sudo /etc/init.d/z-way-server stop
sudo /etc/init.d/zbw_connect stop
  1. Start openHAB again
sudo systemctl start openhab.service
  1. Remove Z-Way again
sudo rm -r /opt/z-way-server
sudo rm -r /etc/*/z-way-server
sudo rm -r /etc/*/zbw*
sudo rm -r /etc/zbw*


sudo apt --purge remove zbw
sudo apt --purge remove z-way-server

Is there any step missing to avoid a mess?

Could Z-Way stay on the system without automatically starting and without messing up openHAB or the update process with openHABian? If so, how?

Hello Thomas
The order of the steps should be okay so.
But I always using sytemctl only to start and stop services.

Maybe you did not

sudo systemctl disable z-way.service

last time?
If not z-way starts automatically after a reboot.
If OH and Z-Way are both running will lead to a mess …

Thanks for the support.

I cannot get Z-Way started on my RaspBerry

openhabian@openHAB:/opt/z-way-server $ ./z-way-server
Z-Way version v3.2.2 from 2021-11-29 15:40:21 +0300 (build 101045968be0f00797fdc4d1a70e2955271fe4e7)
Looking for modules in ./modules
Module loaded
Module loaded
Module loaded
Module loaded
Module loaded
Module loaded
Failed to load module /usr/lib/arm-linux-gnueabihf/ version `MOSQ_1.6' not found (required by ./modules/
Module loaded
Module loaded
Module loaded
Module loaded
Module loaded
Module loaded
Module loaded
Using default configuration file config.xml
Warning: failed to load external entity "config.xml"

Giving up now. Decided, that I will open the walls and replace all Z-Wave devices with Shelly devices and abandon Z-Wave and most likely also openHAB.

Hesitate to post, apologies in advance, but here goes:

Obviously, if the device still works you can set the controller “exclude devices” and perform the magnet or button operation in the manual.

It is impossible (or nearly so- maybe this Zway app works, but I don’t have that setup) to remove a broken battery sensor from OH without the Silabs tool and the Razberry module (you cannot hook it up to a PC USB port -AFAIK).

To remove a failed node there is a two-step process. First is to “set device as failed (OH)” or “check if failed” (Silabs PC controller). The key difference between OH and the Silabs PC controller is that OH will not send a message to a node it considers sleeping, so it does not get marked as failed. The Silabs PC controller will mark a sleeping node as failed (even if it not!) (Since it did not respond-It is sleeping!) and then you can send the “replace failed”.

I happen to generally like Zwave and OH, so I would suggest that if you have access to a windows machine, it might be cheaper to buy a USB Zwave dongle for the Pi, depending on the size of the network (IMHO). If you don’t have a windows machine, it is probably best to ditch zwave since all the Silabs tools are PC based.


1 Like

Really good answer Bob :+1:

1 Like

Thank you for the reply, much appreciated, that you took the effort.

I do not have access to a PC, I am a Mac user.

Zwave with OH works quite well. The problem I am trying to resulted either by failed integration of Sensative Strips (which resulted in nodes not existing) or broken devices (also Sensative Strips and an old FIBARO Home Center Lite, that used as secondary controller to update firmware). Those device physically do not exist anymore, so I am trying to remove them from the controller and openHAB (I ignored them in the inbox or I integrated them as Thing and disabled - both not clean solutions).

Regarding Silabs I found this:

My programming g skills are very very limited. Did programming 40 years back so I will not be able to use it.

However thanks to Bob for the response.