Hp2mqtt - Python proxy for Rademacher HomePilot devices to MQTT binding

Based on the new API for HomePilot and the existing io broker solution I developed a python script to work as proxy between Rademacher HomePilot and MQTT binding of openhab. The idea was inspired by the famous zigbee2mqtt solution.
Yet it doesn’t support all devices e.g. but I use it for my RolloTron rollershutters and an additional actor successfully. I think this first release is a good base to extend.
Maybe it helps somebody or you want to contribute then feel free to have a look here https://github.com/pduck27/hp2mqtt

Hi pduck27,

that looks great for me and could make the future move to OH3 much easier…
Currently trying to move more and more things to MQTT…

I played today a little bit with the docker provided in the git, but endet with some issues…

Mainly the follwing things…
My “did” identifier are just 1, 3, 5, 7, 9, 11 etc
My device type identifier are different… All ends with _A
16234511_A: “RolloTron Comfort DuoFern Gurtwickler 1800-UW”
36500572_A: “DuoFern-RolloTron-Comfort”
32000064_A: “RADEMACHER 9475 DuoFern Umweltsensor”

For all devices,i get the following error message and nothing reported to MQTT
26.12.2020 18:47:52 Search device number for device with did = 1
26.12.2020 18:47:52 Device with did 1 is not configured and will be ignored.

Homepilot2 is on firmware 5.2.23.

Any idea, what could be the reason?

Cheers Alex


your “did” and" device number" look very different to my one’s. Can you run the script with additional parameter -f to get the full configuration of HomePilot and post it here? Or send it via PM?
You will find it in data/device_info.json directory but you must run it without docker.
Another option (maybe easier): You can also browse homepilot with your web browser to get it: http://[Your HomePilot IP address]/v4/devices

Please make sure to gather the right parameters:

Hi pduck27, will share via PM. If we got some more clue, why my Pid is different we can share here…

Cheers Alex