HTTP Basic authentication through VPN not working

I’m trying to connect to an external router via http binding through VPN:

Local computer (Win 10) with openHAB 2.5M1 -> VPN tunnel -> external Router on

String vg_400_bin_in "VG 400 IN [%s]" { http="<[{Authorization=Basic dXNlcm5hbWU6cGFzc3dvcmQ=}:15000:JS(vg_bin_in.js)]" }

In the error logs I get the login screen with username and password, but the binding can’t login.

Is it possible at all to use HTTP Basic authentication through a VPN tunnel?

Thx in advance.

Just to get rid of the obvious, is that the basic auth string you send to the router, or have you used another just here on the forum (which would be wise)? Notices it’s the same as on the http binding docs example.

Are you sure the router accepts basic auth? Maybe you need to add a / after the ip address? Have you tried logging in with basic auth from a browser?

Nope, the one from the binding example. :grinning:
I have the correct credentials in my text file …

Yep, tried that already, unfortunately without success.

Nope, good idea, will try tomorrow when I have access to that network again.

It looks like this is the culprit.
I was not able to login to the router with credentials provided via browser url.
So I guess I’m out of luck here. Thx again.