Http binding doesnt seem to care whats in the http.cfg file

I am using the http binding to get data from weatherunderground. Always worked fine (thanks @rikoshak ).
Anyway, wanted to change the station I am using, so made that change in my http.cfg. In the past that always worked, but now it didnt.

No matter what I change, my UI always shows the ‘old’ station. Well heck, even if I totally remove the http.cfg I still get data from the ‘old’ station.
Tried reinstalling the binding at no prevail. dont recognize any valid errors in the log.
Is there perhaps some shadowfile somewhere?
Any input appreciated

Why you don’t use or do you?
Post you code please.

Have you restarted openHAB?

Are you changing the name of the config?

For example, my config is:


Are you just changing the stuff to the right of the = or are you changing the stuff to the left as well?

When you make the changes, check /var/lib/openhab2/config/org/openhab/http.config and see if the changes appear there. If not:

  1. stop OH
  2. delete /var/lib/openhab2/config/org/openhab/http.config
  3. start OH
  4. check that /var/lib/openhab2/config/org/openhab/http.config is now correct

One final note, look around for other oddness. Sometimes these sorts of inexplicable problems are a sign that your SD card is failing.


Than you,I initially did use the binding and had many problems with it. That is why i switched. Also gives me more control about what I want to parse

I am not unwilling to post the code but it worked for a long time, so it should be OK, it is more a matter of openhab just ignoring the change

[Edit] in the mean time I did find an error in the code somewhere along the line I used a // comment instead of a #. That was not a problem for functioning… untill I wanted to change the station

restart is one of my standards with any problem :slight_smile:

Rich, thanks,
i only changed the name of the config
I checked the http.config file and that had not changed
Deleted it as you instructed
In fact, I already suspected it might be one of those “shadowfiles”

Then indeed the content of the http.config file got corrupted, the http either disappeared or (after some fiddling) had the interval time strapped onto the json.

Then I suddenly realized my mistake, enormeously stupid.
Somewhere along the lines I probably added a “//” comment where it should be a “#” comment.
removed that, everything in order. I am a happy camper again

So what I suspect is that when I set this all up my http.cfg file was ok and got copied ok to the http.config file, but that my cfg file later on got a bit currupted and changes would not get copied to the config file.

Anyway, you pointed me right into the right direction, thanks.

Other ‘oddities’ well yes. Had to twice reinstall MQTT binding, MQTT avtion and SAMBA lately so maybe I shld get a new card, just to be sure.

Again, thanks a lot, like usual you have helped me perfectly

HA! I just did that (only opposite) in one of my rules. I have a bad sensor that is flapping like crazy, either that or my back door is opening and closing so fast the hinges are about to break. So I got on my phone and commented out the three lines in my Rules that generates an alert when the door opens or closes using “#” instead of “//”. I was on my phone so I didn’t have VSCode and I wasn’t tailing the logs.

It took me a few days to figure out why I couldn’t open my garage doors any longer. Those Rules were in the same file which OH now rejects because of the #

It happens to all of us. If we didn’t laugh we would have to cry.

Glad you figured it out. These sorts of errors are hard to figure out.

face palm errors!!
Anyway, you put me on the right track and in hindsight @hr3 made sense as well for asking about my code. I thought… yes but it has worked, it can’ t be my code. Enjoy yr evening