Http binding?


I am new here. I tried to install yesterday my first openhab2 server with openhabian.
I would like to controll my gigablue with the http binding, but the binding is not listed.
The nedded RegEx Transformation is’nt listed as well.
Can anybody help me

Dear Thomas, did you read the documentation at Read through the relevant parts first, then comment back which parts you tried and didn’t understand.

i started to read the docs, but i did’t find the part howto install bindings, or howto download bindings.
Whre exactly can i find it?

Since you have read the Setup tutorial you should have read also that add-ons are installed via the PaperUI.

yes, but i can’t find the http binding in the listed at the PaperUI, so i assume that i did any fault, or that i did’nt install the binding

Confirm you do not see the HTTP Binding under “Add-Ons” “Bindings”.

yes that is in exactly my problem

What kind of setup did you select at the initial setup? By chance “minimal”. You can change it in the file add-ons.cfg.

Looking for this? It’s an 1.x binding. I think you have to enable legacy binding support in PaperUI -> Configuration -> System. Or is this required only for bindings which there is both versions available?

if i remember me correctl i selected “minimal” i will try to change it this evening.
i will change the value “minimal” to ?

i will try it as well

Legacy bindings, are the OH1 bindInga for weich already an OH2 binding exists. HTTP Gas no OH2 binding and should be listed on PaperUI. (unless the minimal config is loaded).


can i chnage it in any file? or should i reinstall the system?

You ned to change it in the "add-ons.cfg " , probably to “standard”. There are comments in the file to help you do it.

The file location is etc/openhab2/services from here you can use something like nano to edit the addons.cfg file e.g sudo nano addons.cfg or use VSCode to edit.

Uncomment package (remove the # at the front) and change minimal to standard then save (In nano Ctrl+X to close then press Y to confirm and save), exit and restart OH.

Thanks for stepping in. Answering while away from the system AND with no working VPN solution (thanks to Dual Stack LITE :rage:) is error prone!

Not a problem, we’ve all been there at some point.:grinning:

thanks it works now.
the package was set to minimal :wink:

Good deal.:sunglasses:

If you would, please mark as solved by clicking the square box (lower right side) on the post that provided the solution.