HTTP ERROR 404 (PaperUI, ClassicUI)

@splatch The UIs redirect to the login page, I see the same on build #1388 - try it out yourself.

Sorry Lukasz … :frowning:
It does not matter what you enter

I entered the correct addresses, tried deleting browser caches, different browsers on different platforms - the entry pages still get redirected to their corresponding login pages.
E.g. http://192.168.1.253:8080/paperui/index.htmlgets redirected to http://192.168.1.253:8080/login?redirect=/paperui/index.html.

Too slow for kai and benno - typing on my phone :slight_smile:

I have created https://github.com/eclipse/smarthome/pull/6351 and think that this should fix the issue.
Will do my best to have this rolled out to openHAB by tonight.

2 Likes

In the meantime, if you’re stuck, this works for me :slight_smile: :

org.eclipse.smarthome.auth:authentication.enabled=“false”

…if the modification of runtime.cfg is done after OH2 start

3 Likes

Thanks, @glhopital! The double quotes around false did the trick for me without restarting OH2.

Turning Karaf authentication off ( org.eclipse.smarthome.auth:authentication.enabled=false in /etc/openhab2/services/runtime.cfg) fixed that for me.
For those where that didn’t work, did you clear the browser cache ?

It appears that if you set

org.eclipse.smarthome.auth:authentication.enabled=false in /etc/openhab2/services/runtime.cfg

then reboot the problem returns, but if you edit the file again (I assume forcing a reread) the problem goes away. Not sure why this is happening but it in summary if you edit the file with a running openhab it will temporarily fix the problem, if you restart it will come back.

New distro #1389 includes this fix and works for me. No setting of any parameter should be required.

2 Likes

I just did the upgrade and can confirm it works for me too. - Thanks @Kai for getting this solution out there.

1 Like

I can confirm - with the new #1389 distro the problem has gone. Many thanks to all of you.

Yes, the lastest update fixes the problem. Thank you.

Still a no go for me.

Updated to #1389 via apt-get and cleared browser cache. I still cannot access PaperUI, BasicUI or ClassicUI. It’s still trying to redirect to /login.

Works well again with 1389.

and Karaf cache, too ?

Yes, that is done automatically when using apt-get but I issued an:
openhab-cli clean-cache
after the update just to be sure (after stopping openhab, of course).

I’m open to any other suggestions.

1390 works like a charm! :slight_smile:

@wborn: Do you have any guess when we might expect password protection for the UIs? Sounds like a very reasonable feature… :slight_smile:

Thanks!

Check (or maybe even better help on) https://github.com/openhab/openhab-distro/issues/791!

Hmm, looking at my coding abilities, preferably I should not provide code :wink: