HTTP ERROR 404 (PaperUI, ClassicUI)



to runtime.cfg, restarted, deleted cache - still redirects to login page (Paper UI, Basic UI, Classic UI). Build #1388

Please pay attention URIs in your browser - paperui might work, but your browser was earlier redirected to non existent /login page. Assuming that you adjusted authentication configuration - /paperui, /basicui should work just fine.

Above issue affects development snapshot, meaning a unreleased version. Its not final and that’s why its so shaky. Final release won’t be like that. We will provide better documentation for this feature once stabilized. Your experiences confirm that there is still some work in order to mark stuff as done.

I am not able to guess how all your local environments looks a like, but I did run builds which you reported as broken and I could not reproduce issue with vanilla installation. Neither with build #1388 nor #1383. Logging in this area is quite laconic as there is literally one if statement which determines if security is enabled or not.

1 Like

That is working instantly.

Yes that worked for me, too. Instantly, no restart. I’m on #1387.
I’ve added this to the warnings you’ll get on installing packages.

Sorry, but this does not work on #1388 :frowning:
Classic/Basic/Paper-UI still fail with: Problem accessing /login. Reason: Not Found

(we are using ‘runtime/bin/update 2.4.0-SNAPSHOT’ so no way back …

Same for me. At least the app and every other UI (except paper/classic/basic) is working when disabling auth. For the time being this is sufficient for me and the waf :wink:

@BLange, @_tom The /login page doesn’t exist and won’t appear any time soon. That’s why I wrote you need to enter paperui in address bar. You can also go back to OpenHab dashboard/front page.

Please post screenshots of your browsers.

@splatch The UIs redirect to the login page, I see the same on build #1388 - try it out yourself.

Sorry Lukasz … :frowning:
It does not matter what you enter

I entered the correct addresses, tried deleting browser caches, different browsers on different platforms - the entry pages still get redirected to their corresponding login pages.
E.g. redirected to

Too slow for kai and benno - typing on my phone :slight_smile:

I have created and think that this should fix the issue.
Will do my best to have this rolled out to openHAB by tonight.


In the meantime, if you’re stuck, this works for me :slight_smile: :


…if the modification of runtime.cfg is done after OH2 start


Thanks, @glhopital! The double quotes around false did the trick for me without restarting OH2.

Turning Karaf authentication off ( org.eclipse.smarthome.auth:authentication.enabled=false in /etc/openhab2/services/runtime.cfg) fixed that for me.
For those where that didn’t work, did you clear the browser cache ?

It appears that if you set

org.eclipse.smarthome.auth:authentication.enabled=false in /etc/openhab2/services/runtime.cfg

then reboot the problem returns, but if you edit the file again (I assume forcing a reread) the problem goes away. Not sure why this is happening but it in summary if you edit the file with a running openhab it will temporarily fix the problem, if you restart it will come back.

New distro #1389 includes this fix and works for me. No setting of any parameter should be required.


I just did the upgrade and can confirm it works for me too. - Thanks @Kai for getting this solution out there.

1 Like

I can confirm - with the new #1389 distro the problem has gone. Many thanks to all of you.

Yes, the lastest update fixes the problem. Thank you.

Still a no go for me.

Updated to #1389 via apt-get and cleared browser cache. I still cannot access PaperUI, BasicUI or ClassicUI. It’s still trying to redirect to /login.