HTTP ERROR 404 (PaperUI, ClassicUI)

sudo apt-cache show openhab2
sudo apt-cache show openhab2-addons

Then select the version you want to install.

sudo apt-get install openhab2=2.4.0~20181004001205-1 openhab2-addons =2.4.0~20181004001205-1

1 Like

I went back to #1383 and #1380 but I still have the 404 problem on accessing BasicUI or PaperUI.
OH still changes e.g. accesses to https://<ip>:<port>/basicui/app into https://<ip>:<port>/login?redirect=/basicui/app which does not exist.
Seems the upgrade to #1386 has put than into some config file that isn’t changed back on downgrading.
Anyone to know how to get rid of that ?

Sorry maybe for the impatience - but in #1386 i now see consistently login request pop ups for all UIs as well as authentication request from IOS app (at least before 1386 the app still worked as a last resort)…is there any default credentials that could be entered in order to make it work for now…or no way i could overcome the pop up?

If the error is because of authentication, shouldn’t it be returning a 403 error instead of 404?

I’m happy to see this one finally addressed.

I’m not saying that we are not interpreting the problem here, I’m saying that had it returned 403 it might have clued us in earlier that authentication was the problem. From a usability perspective, if I enter my authentication in incorrectly I hope to get a 403 instead of 404 at least.

Got bit by this as well. Downgraded and turned off my auto update for the time being. It did take me a few tries(stop/clean/start) to get things working again after the downgrade, but eventually have it all working.

Ive stopped the expiration of the snapshot apt/yum packages until the issue is sorted. This will keep a working version in the repo for a while.

As others have mentioned:

sudo apt install openhab2=2.4.0~20181006154235-1 openhab2-addons=2.4.0~20181006154235-1

Will downgrade and restart openhab to the last version without the authentication change. Applying the installation as in above line will clear the cache for you.

After the problem is fixed, you can upgrade normally and uninstall openhab2-addons if you wish to use the online repo (and save space).


Just tried #1387 - indeed the login user/pw has disappeared however trying to access Basic UI, Classic UI or Paper UI still thow a HTTP 404 error “not found”

@rlkoshak I believe the error is 404 as it can’t find the page /login so although if it found it you wouldn’t be able to login the first error is can’t find the log in page - 404- Error Page Not Found

1 Like

I checked affected build from yesterday and it worked fine once I switched off the authentication. Can you please give a try to set/unset authentication.enabled flag and see how system behaves after restart?

By default when authentication is disabled there are no checks, nothing at all - access is just granted. If you see any prompts it means that authentication is still somehow enabled.

would that be an entry in runtime.cfg or where would we need to put that ?

Can you also comment on my post #26 please ? Still having this problem with #1387 and seems I’m not the only one.

Yes, its runtime.cfg, the 404 is result of authentication handler who still execute its logic (and following handlers).

Unsure of the syntax… I added

##################### AUTHENTICATION ####################

to runtime.cfg and restarted, would that be the right syntax ?

There’s no visible effect to me, still get that 404 on accessing BasicUI.

ok, but how to get rid of it ? Should authentication=OFF do that trick?

Adding authentication.enabled=false to runtime.cfg followed by stopping openhab, cleaning the cache & then starting openhab also doesn’t work for me.
Still redirects to \login

Is it




? (both don’t work)

Just updated to #1388. Still redirects to \login. Tried it with:

authentication.enabled=false -> Does not work
org.eclipse.smarthome.authentication.enabled=false -> Does not work
org.eclipse.smarthome.authentication:enabled=false - Does not work

I am also struggling with this issue. But HABmin is working, but I can not controll the sitemap from there. looking forward to a solution :slight_smile:

@xx88 Update now the IOS app works again…at least.

Valid syntax in runtime.cfg to disable auth is:

Make sure you don’t leave any # in beginning. @Dibbler42, @_tom, @mstormi - can you check this? Please restart after change if it doesn’t change anything.

That worked perfect, even without restart!

Thx :slight_smile:

It did only work until I restarted. Now I still have the issue :frowning:

This fixed the auth issue and 404 for me. I recommend it.