HTTP ERROR 404 Problem accessing /start/index. Reason: Not Found

  • Platform information: Raspberry pi 3B
    • Hardware: CPUArchitecture/RAM/storage
  • OS: Raspbian jessie
  • Java Runtime Environment: Java 8
  • openHAB version: OpenHAB2
  • Issue of the topic: Unable to
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

I am very much beginner and not tech guy.

Earlier everything was working fine. However, when I tried to connect to OpenHAB cloud, the system was showing OFFLINE. When worked around in community, came to know the problem might be with java. Hence, installed java8. After then, I could not access

Java is listening to Port 8080.
Please help. Many searches in forum didn’t solve the problem.

In console type:

java -version

What do you get?

pi@raspberrypi:~ $ java -version
java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode

Start by updating you java we are on 1.8.0_161

Thanks for reply.
I’ve updated the java by removing 65 version and installed 162 from java site.

pi@raspberrypi:~ $ java -version
java version “1.8.0_162”
Java™ SE Runtime Environment (build 1.8.0_162-b12)
Java HotSpot™ Client VM (build 25.162-b12, mixed mode)

But, still not working.

When I try to check status of openhab2 service, I get following result. Why java in listening to 8080? Is that correct? And why java is main PID in openhab2 service?

pi@raspberrypi:~ $ sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service
Active: active (running) since Sat 2018-04-07 07:59:48 I
T; 1min 40s ago
Main PID: 563 (java)
CGroup: /system.slice/openhab2.service
└─563 /usr/bin/java -Dopenhab.home=/usr/share/…

Apr 07 07:59:48 raspberrypi systemd[1]: Started openHAB 2…
Hint: Some lines were ellipsized, use -l to show in full.