HTTP ERROR 500 - Sitemap 'default' could not be found


i try to add the file default.sitemap to “/etc/openhab2/sitemaps” still same issue

what more can i do?


Problem accessing / Reason:

Sitemap 'default' could not be found

Caused by:

org.openhab.ui.webapp.render.RenderException: Sitemap ‘default’ could not be found
at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.servi

Which installation did you take? Simple, Standart, Expert or Demo?
If you are new to openHAB I would highly suggest you should use the Demo. :slight_smile:
Also check this out Creating a sitemap


what now? how can i make it to run? i get this error

post the contents of the default.sitemap file to check

Hey Dim,

The file is empty i just create it, the file wes missing…

Put something within the file.

The name of the sitemap is important, not the filename (these 2 should be the same anyway).

Use something simple like:

sitemap default label="My default test" {
Frame label="Test" { }

For more details, see:

1 Like


file o past default.sitemap and add what you tell me.

i read i do not understand it

every time same error on

Does it work ok now? (does the new sitemap load correctly?)

To set is as default, go to Paper UI -> Configuration -> Services -> Basic UI -> Configure -> Default Sitemap

Nop still same error, need to restart the system?

i’m try with systemctl restart openhab2

it’s not needed to restart OH2 when managing sitemaps… it loads them up automatically…

does the following URL work ?

Isn’t his path wrong? My path is /openhab2/conf/sitemaps/default.sitemap

No, still i try it i read it here…

i just add one item and after that is stop working,

Thanks for try to help

Not necessarily.

Most likely, you are using openHABian or a manual deployment (correct?) and this uses another subdirectory structure.

The most usualy deployment is via apt-get and this puts the config files in /etc/openhab2. For more details, see here:

1 Like

i do not have this path …

I typed wrong the URL in the previous post (I fixed it)



Problem accessing /basicui/app. Reason:

ProxyServlet: /basicui/app


Ok… let’s do some basic troubleshooting then…
Which version of OH2 are you running? (Beta, RC1, Final, Snapshot). Check file /var/lib/openhab2/etc/ or use Karaf console.
Does Paper UI work? What do you see when you navigate to ?
In Paper UI -> Add-Ons -> User Interfaces, does Basic UI appear as installed?


Maybe I was not clear, I can not even enter to the HO2.
So i cannot enter to any of item on HO2

openHAB Distribution Version Information

build-no : Build #752
online-repo :

Repository Version

openhab-distro : 2.1.0-SNAPSHOT
smarthome : 0.9.0-SNAPSHOT
openhab-core : 2.1.0-SNAPSHOT
openhab1-addons : 1.10.0-SNAPSHOT
openhab2-addons : 2.1.0-SNAPSHOT
karaf : 4.0.8

What happens when you navigate to ? (or
This error comes up automatically?

I don’t recall using in my OH2 system… maybe this is from the OH1 world…?


Problem accessing /paperui/index.html. Reason:

ProxyServlet: /paperui/index.html 


for add automatic

i see also openhab and openhab2 via SSH,

can i uninstall openhab1? may this the issue?