Https://openhabian:8080 doesn't work, but http works OK. SSL_ERROR_RX_RECORD_TOO_LONG

  • Platform information:
    • Hardware: RPI/4GB
openhabian@openhabian:~ $ uname -a
Linux openhabian 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux
  • OS: openhabian 1.8b
  • Java Runtime Environment: whatever is on openhabian 1.8b
  • Issue of the topic: https://openhabian:8080 doesn’t work, but http works OK

The error:

Secure Connection Failed

An error occurred during a connection to openhabian:8080

. SSL received a record that exceeded the maximum permissible length.


    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

It’s a fresh install + migration of settings from previous machine using backup & restore method. I also added openhabian hostname to the router (Turris Omnia) configuration.

Can I provide more info to help with diagnosing where is the problem? I’m using a router provided by the internet provider and Turris Omnia ar the real router serving LAN. Could that make a problem with obtaining the cert?

8080 is the HTTP port, for HTTPS, please use port 8443.

1 Like

Once you use the correct port in your URL the next thing you will see is your browser complaining it is a unsecure connection.
That is due to openhab uses a self signed certificate. In order for you to solution that you simply need to export the cert from your browser session and import it to your trusted root certificate authority key store and it will not keep warning you it is unsecure.

1 Like