Hi all.
My openhab server does not support https protocol (i.e. only http protocol is supported) so the android app cannot connect to the server. How can I handle such an issue?
Thanks in advance

Did you do something to disable HTTPS on the OH server? It’s there by default on port 8443. You would have had to do something to disable it.

Just enter http://<ip or hostname>:8080/ to have the app connect over the HTTP port

For local connections the app can do http, but like @rlkoshak said that the openHAB server does https by default. You can also install a reverse proxy to handle https.

As @rlkoshak suggests tried the 8444 port and I can connect but not with the admin privileges. As @mueller-ma tips I will try with a reverse proxy as well