Hue Bridge isn't detected with OH2

Hi guys,

I have installed OH2 (using openHABian). Then I installed habmin and the zwave binding without problems. My zwave devices where found as things. I also tried other bindings (Yahoo weather e.g.) and all gave me the result I expected.

What I couldn’t get to run is the HUE binding. I installed the binding through PaperUI and then started a thing discovery. With no result. And I mean: NO result. :frowning: Nothing found and also NO single log entry. I set the log level to DEBUG of course but no luck. I tried the same with HABmin, also no hue bridge thing found. Is this possible? Or have I made a mistake with the log command?

I checked if the binding is active. PaperUI, HABmin and also command “bundle:list” all show the binding as active.
Then I thought: Ok, the bridge is found via uPNP, maybe that’s the problem. So I quickly checked another uPNP-device-binding (AVM Fritzbox) and the device was found properly.

Some further notes: I am using the “newer” v2 of the bridge (home kit compatible) and I have used the bridge without any problems on my OH1.8.3 installation.

Any thoughts?

Strange… mine is working very well at first click was found…

I finally got it to work. But the automatic thing discovery of the bridge did not do the job. I had to add the bridge thing manually. But this was easier than expected. I only had to enter the IP of the bridge. After that I pressed the button of the bridge to pair it. The log then successfully recognized the bridge and even the user name was automatically transferred to the settings of the thing in PaperUI. Bridge was fully functional then and the lambs where also immediately found.

Maybe this helps someone with similar problems.

Glad to hear that you have it working, but it does not answer, why discovery didn’t work.
As it usually works without any issue, I would guess that it is due to your local network; maybe your router swallows some UPnP messages or messages are sent on a different network interface.

@Kai Yes, maybe this wasa local problem with my network.

But what I wanted to let you know anyway: It took quite a while for me to find out the “correct” package name of the hue binding to set the appropriate DEBUG command. Often the zwave binding is mentioned here, which has “org.openhab.binding.zwave” (AFAIK), but the HUE binding doesn’t has (as maybe expected) org.openhab.binding.hue. I still do not know which one finally was the correct one, but I used the following command:

log:set DEBUG org.eclipse.smarthome.binding.hue
log:set DEBUG org.eclipse.smarthome.hue

Maybe this should be mentioned anywhere in the docs?