Hue Emulation basic setup issues --> "Not Authorized"

Hello All,
I’m quite new to the community and I have been reading all I could find on this topic. Unfortunately I hit a (probably rather stupid) block:

  1. I have enabled Hue Emulation in Paper UI and it shows now under Configuration/Services
  2. Then I have tried the links as proposed in the Setup article:
    –> with following result (looks as expected)
<root><specVersion><major>1</major><minor>0</minor></specVersion><URLBase></URLBase><device><deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType><friendlyName>openHAB Hue Emulation (</friendlyName><manufacturer>Royal Philips Electronics</manufacturer><manufacturerURL></manufacturerURL><modelDescription>Philips hue compatible Personal Wireless Lighting</modelDescription><modelName>Philips hue bridge 2015</modelName><modelNumber>BSB002</modelNumber><modelURL></modelURL><serialNumber>7AB1F6B03281</serialNumber><UDN>uuid:7ab1f6b0-3281-48ae-8d89-8075e2410521</UDN><presentationURL>index.html</presentationURL><iconList><icon><mimetype>image/png</mimetype><height>48</height><width>48</width><depth>24</depth><url>hue_logo_0.png</url></icon><icon><mimetype>image/png</mimetype><height>120</height><width>120</width><depth>24</depth><url>hue_logo_3.png</url></icon></iconList></device></root>
  1. Next I tried:
    –> with following result:

[{“error”:{“address”:"/testuser/lights",“description”:“Not Authorized”,“type”:1}}]

I keep ending up with this result and I can’t find a clue how to overcome this.
BTW: I created a .items file which is probably not quite correct in syntax yet, but that shouldn’t be the cause of a “Not Authorized” error, right?
Also: There is no entry in the log files, when I call the URL.

Help would be very much appreciated. I’m sure it must be some beginners error…

What are you trying to do?

Ehm. Have you read the entire binding documentation? :wink: At the beginning it says, that it need to be put in the “authorise mode” like the real Hue bridge and you do this in Paper UI by going to the “Service” section, find Hue Emulation and switch the toggle.

I’m trying to expose some things via hue emulation so I can pick them up with Alexa.

I did this in paper UI. Yes, I switched the discovery mode ( or whatever it’s called) on.
Still got the authorisation error. But I will double check tomorrow.

I am struggling with the same stuff (Alexa does not find anything).
A few releases ago I got it to work properly.

  1. I have tagged some items
  2. HUE Emu is obviously running well
    2019-01-05 14:42:07.583 [DEBUG] [.io.hueemulation.internal.LightItems] - Added items: Ranzen, Kaffeemaschine, Verstärker, Alles, Licht, Echo Dot, Wand-Licht, Treppen-Licht
  3. I set in Paper UI both DevicePairing and Amazon Device Discovery Fix to ON
    (pairingEnabled=true and createNewUserOnEveryEndpoint=true)
  4. Seach for new Devices on the Alexa App without success.

Which one are you referring to?
This one does not mention any authorization (and I don’t remember that I did it few months ago, when I was successful):

By the way, I can discover the items with my harmony hub and the items works just fine with Harmony.

After deleting all Devices on and new discovery I just got “Verstärker” (Dimmable Light)

Another finding:
Only Dimmer items are discovered.
Double checked the “Switchable” items, but no obvious mistake… :frowning:

Known issue:

1 Like

The Switchable issue still exists, but the workaround is discussed in the topic. However, there have been several things fixed post 2.4 in the snapshots. OTOMH, groups now work, groups now also work without a type (as previously), and the levels set are now correct (previously off by 1).

I did not see that thread.
I just saw the others with the discovery issues in many variations.

1 Like

Did you get a fix for this? (The authorization problem and not the device discovery problem). Mine’s acting in the same way since I upgraded my Philips Hue with the app. (My real hue isn’t working either with the same problem).


I know in the Alexa app if you are adding a new device it asks if Hue Ver1 or Ver2. I’m not really sure which version our Hue Emulator is masking as, others need to reply. Is it possible that we have a version difference between Alexa and the OH Hue Emulation bridge?

Version 2 is emulated. But could be that Philips introduced new mechanics recently and Amazon is already using them, which makes the hue emulation incompatible. Just a guess. It worked for me a month ago.

Has it stopped working recently or is your’s working?

I still can’t get my hue emulation service or Philips hue binding to accept a username.

I’ve cleared the caches, deleted the jsondb database entries, re-installed the service, and the binding, deleted and recreated the hue emulation thing etc etc etc.

It all worked perfectly previously until I updated the hue app.

Has anyone any ideas?


I haven’t tried to re-authenticate recently.
The hue app will not work anyway, we are not emulating good enough /accurate enough.

I got the Philips Hue username using this post and now my Hue is back online.

Obviously this workaround won’t work for obtaining the hue emulation username so I’m still open to ideas.


Maybe I get something wrong, but why exactly are you using the emulated hue bridge as a thing ?
The binding discovers it, I know.
But all the devices you will get through this bridge are the emulated ones from openHAB.
And those devices are already present in OH. More or less a circular reference…

So from my perspective there is no need to have a thing representing it, thus I would say that you can just ignore that thing as the actual magic lies within the Hue emulation service.